Request Create Property Panel Invalid Module Bug?

I have tried building a request to create a property panel module based on the ACE JSM example. However, I am getting the following error:

"subCode":"connect.install.error.unknown.module",
"errorMessage":"Installation failed. The app defined an unknown module (serviceDeskPortalRequestCreatePropertyPanel). Please <a href=\"https://marketplace.atlassian.com/plugins/my-app/cloud/support\">contact the app vendor</a>."

I copy pasted the title of the module from the documentation so I don’t think I have a typo. I have also checked that the rest of my app definition is as per the docs. Here my full atlassian-connect.json

{
    "key": "my-app",
    "name": "My app",
    "description": "My very first app",
    "baseUrl": "{{localBaseUrl}}",
    "authentication": {
        "type": "jwt"
    },
    "lifecycle": {
        "installed": "/installed"
    },
    "scopes": [
        "READ"
    ],
    "apiMigrations": {
        "signed-install": true
    },
    "modules": {
        "serviceDeskPortalRequestCreatePropertyPanel": [
            {
                "key": "jsm-property-panel",
                "url": "/App"
            }
        ]
    }
}

It would be really appreciated if you could help me out with this. Are the docs outdated? Is there a bug in the system? Or is this module maybe incompatible with ACE?

Hi @MichaelIlewicz ,

The correct module name is serviceDeskPortalRequestCreatePropertyPanels with the s at the end.

Try that out and let me know!

Cheers,
Caterina