Rest/api/3/issue/createmeta not available on OAuth2.0

After calling
https://api.atlassian.com/ex/jira/ladskf-jjdslf1o3-409d0fa/rest/api/3/issue/createmeta
the server returns.

HTTP 403
{ errorMessages: [ 'OAuth 2.0 is not enabled for this method.' ] }

That’s a major bummer as we’re looking to find the issue type metadata for a project to allow users to create new issues.

Do you know if this restriction is intentional or if there are any other way to unblock issue creation using 3LO ?

Thanks in advance!

I just tested this API with 3LO and it worked for me. Are you still getting the same error? It might have been a transient issue.

Thanks @kkercz, and sorry for the delayed response.

Yes, I am still getting the same error. I connected our API app with OAuth 2.0. Here is the prompt shown by Atlassian on connection

Then, I set the bearer token on the API request.

Are there any other permissions I should enable when connecting the API app? What does this screen look for you?

I have the exact same issue. I’ve been successfully calling the https://api.atlassian.com/ex/jira/${accountID}/rest/api/3/issue API to create new issues, but I don’t want to hardcode the issue type. Instead, I’d like to discover it using the https://api.atlassian.com/ex/jira/${accountID}/rest/api/3/createmeta API call. But I get the same 403 error (OAuth 2.0 is not enabled for this method).

Is there any workaround for this?

Apologies - right after I posted this, I realized that my request URL was missing a component:

https://api.atlassian.com/ex/jira/${accountID}/rest/api/3/issue/createmeta

After correcting the URL, the API works fine!