Sending app for approval does not work

Hi everyone,

together with a colleague I recently developed an app for Jira server. We created a vendor account and I uploaded the app which is now private. I tried to make the app public and filled in all required information. However, whenever I am in the final steps screen accepting the publisher agreement and click on submit, I get redirected to the “getting started” step at the beginning. My inserted data remains and I can click through all steps again but at the end it is the same result.
An approval ticket as written in the documentation isn’t created as well. Has anyone heard about this problem? Or am I doing something wrong?
I also created a support ticket in the marketplace service desk, but unfortunately got no answer so far :frowning:
The ticket is AMKTHELP-16500

Thanks for any help in advance!

Hi @ij-s,

Apologies for the delay in responding to your Support Ticket.
We have raised this issue with the concerned dev team and it will be fixed soon.

Can you please add a link to the Data security and privacy statement field and retry to publish the app? This should submit your application for the approval process.


Hi @ayarazarvi,

thank you very much for your answer.
The point with the data security statement definitly makes sense. The approval request was now started :+1:
Maybe the respective field should be labeled as required or an error message should appear.


Yes, you are right. The suggested changes will be live soon.