Server addons: Compatibilty - how old releases should I support?

When we develop addons for server releases (in my case, Bitbucket Server), for each new release I make, I need to validate compatibility with specific versions.

The list allows me to select anything from version 1.0.0 to the latest (often one more than released). However, it’s a bit hard to know what is the earliest releases that is still supported by Atlassian.

For example, right now I can see from app statistics that we have customers still running Bitbucket Server 5.8.0 - does it make sense for me to keep supporting and validating this in all new releases?
Or would it make more sense to stick to supporting the latest LTS (Enterprise) release and this way, give more reasons for customers to upgrade to a later release of Bitbucket?

I know this is currently my own choice, and I do tend to check with whatever my customers are running. But it would be nice to have a recommendation from Atlassian that could be used as a motivator to drop support for old releases.

It depends on what your goal is. By setting a wider compatibility range you of course open yourself to a wider market so this can be a good idea especially for new apps.

For maintenance releases and updates of established apps we usually look at Atlassians EOL page and choose our compatibility ranges based on that. By this you ensure that only instances that are reasonably up to date will be able to use your new version. This is especially a good idea if you have a large support volume and only want to support new versions.

In the end it probably doesn’t really make a difference unless you’re too restrictive. I think supporting at least all the versions that are still supported by Atlassian as well is a good idea. :slight_smile:


1 Like

Thanks, this was exactly the page I wanted to find! I’ll adjust my testing accordingly and next release I make will support Bitbucket Server 5.12+

(Unless of course some customer specifically requests supporting something else).

1 Like


In our case, we look at the EOL matrix but take into account the Atlassian APIs as well to go as far back as possible. For example, according to the EOL table, we should at least support Jira 7.12 but our code uses API that are available from Jira 7.2 so we claim compatibility from Jira 7.2.

Over time, we learned that the furthest you support the better … as long as it’s the same executable.

1 Like

Thanks, yeah, that’s what I have been doing so far but started wondering if I’m just creating a larger support-problem for myself in the long run.

Honestly, I don’t think you are. It’s the same code base and quite frankly there aren’t that much people using old versions. I think I remember only one guy that I had to fix something for an older version of Jira. And it looks much better on the Marketplace when the person trying your App sees that you are supporting a wide range of versions.

1 Like