Simplified user consent for Forge (Preview)

Hi @PhilipFeldmann

I’ve tried the latest version of your app in my site and that worked fine. I did however see a period in our logs where it looks like the app installation was still pending which would cause the auto-consent to fail (in as you said your site around Aug 3, 8am UCT and the other earlier on Aug 2, 9am-10am UCT)

I wonder if the issue is still happening at the moment. As far as I can see your installation has been completed since and the other one is gone (uninstalled?) - if it is still not working, reinstalling the app and giving it a bit of time to sync across the products might solve the issue.

If the issue persists, I would need some more information that is probably not wise to ask on a public forum. If so, please create a ticket at Jira Service Management with segment Forge, and Ecosystem Cloud products Other and add my name and or a link to this conversation to it so it will be routed to me.

1 Like

Hi, I have tried to include autoUserConsent into my manifest, but it still doesn’t work.
Do I need to change any version number from package.json?

id: ari:cloud:ecosystem::app/3a6ad978-4f58-46b2-82cc-3afdf697e77e
autoUserConsent: true

do a test

This change triggers a major update, maybe you haven’t updated the app manually in the UPM?

@ShaunNg thanks for raising this. We’ve discovered a bug introduced on Monday (as part of the preparation for GA) that means the simplified flow has not been applied to any apps that tried to adopt it this week.

We have rolled back this change now, but for your app you’ll need to:

  1. Remove autoUserConsent: true from your manifest and re-deploy
  2. Add autoUserConsent: true back into your manifest and re-deploy


1 Like

Hi Adam,

Thanks, it worked! (At least now I see the “Update” button after I re-deployed the change).
And I tested it in sandbox, it is working nicely, now the users can edit the template the first time they add it.

Thanks again.

1 Like

Hello Adam thanks for the info! One thing I noticed is if I’m deploying a new forge app for the first time and the manifest does contain the autoUserConsent property, it successfully deploys but can’t install because it says a deployment was not found. I have to first deploy without the autoUserConsent then with it for it to be able to be installed.

2 posts were split to a new topic: Why does Forge autoUserConsent still asks for user consent?