Sites not coming during Forge app installation via installation link

We developed an app using Forge framework which does Asset imports in JSM Asset platform. For sharing the app within the team, we created an app installation link by following these steps.

We have enabled Jira product while creating the installation link.

The users are the admin of the site and wants to install app in that site. They are not able to see the site in the Choose a site option which comes while installing app via link.

Permissions in the app manifest:

      - unsafe-inline
    - storage:app
    - read:jira-user
    - read:servicedesk-request

Does the above option only shows the sites with Jira software configured?
If so, how can we share the app to a user who has a site with only Jira Service Management configured?

Also, Can this be confirmed that when the app would be published on marketplace, it would be downloadable for all the users either of Jira Software or Jira Service Management?

Hi @SagarGujarati

Thanks for your question. Let me confirm this with our team.

I got an update from our team that we are aware of this issue and it is currently being worked on. We will make the announcement when it’s available. :slight_smile:

@aagrawal2 Thanks for the update.

We now have a tutorial on importing third party data into Jira Assets using Forge. Do check it out and let us know :slight_smile:

Hi @aagrawal2 Thanks for the update related to the new tutorial for JSM Asset imports.

I tried following the steps provided in the tutorial. Though the new UI component seems to work fine, I faced the below issue while calling the Imports REST API using the asUser method.

The API works fine for the /executions endpoint but gives 401 error when I try to call /mapping endpoint with PATCH method. Below is the code snippet:

const asUserRequest = await api
        method: "PATCH",
        body: JSON.stringify(commonSchemaPayload),

And the response I am getting:

{ "code": 401, "message": "Unauthorized; scope does not match" }

Permissions in the app manifest:

      - unsafe-inline
    - storage:app
    - import:import-configuration:cmdb

Can you check with the dev/support team if I am missing something here?
Let me know if more information is required.

I have reached out to our internal team about this. We will update you soon.

Hi. There was some issue from our side. We have fixed it. Could you please try again and let us know if it is working fine?

Hi @aagrawal2,
I checked again and it is working now for PATCH requests. Thanks for the update.

1 Like