Space Blueprint Tutorial hangs when hitting Create button in Create Space

Starting a few weeks ago, I’ve been working on developing a space blueprint by following the [Space Blueprint tutorial|https://developer.atlassian.com/server/confluence/write-a-simple-confluence-space-blueprint/]. Everything worked fine the first few times I did it, starting over from scratch each time, but yesterday it started hanging up when I hit the Create button after selecting my space blueprint in the Create Space dialog. When I hit create, the spinning wheel appears next to the create button, and nothing happens.

I looked at the logs, and when this happens I get this error:

[INFO] [talledLocalContainer] 2018-02-18 02:17:44,716 WARN [http-nio-1990-exec-5] [webresource] writeTo error in `Content.writeTo` for com.example.plugins.tutorial.confluence.spacebp.spacebp:spacebp-resources/dialog-page.js
[INFO] [talledLocalContainer]  -- referer: http://localhost:1990/confluence/index.action | url: /confluence/s/1c670ec575969ff8afd8179c1eb41184-CDN/en_GB/7400/NOCACHE/29b2d9f335e47aec9b954047cf18add0/_/download/contextbatch/js/dashboard,backbone-dashboard,atl.general,main,-_super/batch.js | traceId: cc69e674fb206f07 | userName: admin
[INFO] [talledLocalContainer] com.atlassian.soy.impl.QuieterSoySyntaxException: In file /soy/dialog-page.soy: SoyDoc not at start of line [line 2, column 8].

In order to get this error, I’ve follow the tutorial exactly, copying and pasting the code in the tutorial into files exactly as instructed. The plugin was created with the following (using Windows 10, jdk version 1.8.0.152 and atlassian SDK version 6.3.6):

    <groupId>com.example.plugins.tutorial.confluence.spacebp</groupId>
    <artifactId>spacebp</artifactId>
    <version>1.0.0-SNAPSHOT</version>

I followed the same steps the first few times I created a plugin and it worked, but now I get this error message, and I’ve tried it on multiple different computers (and a friend tried the tutorial as well) and still get the exact same error message. I can post the exact code in the files I’m using, but since I’m just copying and pasting from the tutorial I’m not sure if that’d be helpful.

The error message seems to suggest it’s a problem with the dialog-page.soy file the tutorial has me create, which seems to make sense as it tries to open the dialog page when I hit the create button, but the dialog-page.soy file is exactly what the tutorial says it should be.

If anyone has any ideas or suggestions about what I’m doing wrong, I would greatly appreciate it!

Edit to add:

I tried running cmd.exe in administrator mode in case it was a write permissions error, but that didn’t change anything.

@RossMcCoy I’ve been working to reproduce this, however on my Mac I’m not having much luck. One thing I’d suggest is that you check your base URL is set correctly - if you’re accessing confluence at localhost:1990/confluence then you should update your baseURL to match in the Confluence general configuration.

If that doesn’t help, would you also provide the section from your pom.xml?

You can find my source at https://bitbucket.org/serverecosystem/confspaceblueprint/

Cheers,
Melissa