Status rest endpoint returns error, but addon working fine

I’m currently developing on two add-ons for Jira/JSD cloud, that have a very similar configuration. I let atlassian-connect-express install both automatically on server startup. That works fine. But one displays an error message after a successful installation:

Failed to register with host (200)
The add-on descriptor failed to validate against the schema. Please confirm this add-on is intended for use with JIRA and then contact the add-on vendor.

  • /baseUrl: string "{{localBaseUrl}}" is not a valid URI

This is a result of the rest endpoint /rest/plugins/1.0/pending/[plugin-key].

The localBaseUrl in both atlassian-connect.json files are identically. I can install the failing addon manually without error message. The rest endpoint call returns the same error message as the automatic addon installation.

My atlassian-connect-express version is 3.1.0

Any ideas? Is this a problem, or can I just ignore?

Sounds odd, maybe a subtle and possibly invisible difference in the app descriptor schema (e.g. an invisible Unicode character like a BOM)? Have you tried to validate the schema with the Atlassian Connect descriptor validator (not sure it’'s still up to date though?