(Trello) Issue with power-ups capabilities

Hi guys!

I started designing a custom Trello power-up and I encountered a couple of problems.
Once I managed to have a basic power-up into Trello, I added it to a board. It worked (the implementation, that is).

However, no matter what capabilities I activate in its settings (and code them in their respective fashion), the features do not show up in the power-up. For instance, I tried to implement a card button, using the sample code found here.

When I do so, the button doesn’t appear:

Here is the repository where I stored my code. It might help figuring out what is not working.

Do you have any idea what might be wrong here? Could it be because the client.js file is not in the same directory as the index.html one?

Thank you very much!

Isn’t it just because you don’t have a callback - I am not sure if it is mandatory?

Close! I think it is because client.js isn’t being loaded on the page: learning-trello/index.html at master · yaeldemers/learning-trello · GitHub

You have:


<!DOCTYPE html>
<html>
  <head>
    <meta charset="utf-8">
  </head>
  <body>
    <h1>Hello World! 🔥</h1>

    <p>This is the HTML connector for the Power-Up. It is loaded into a hidden iframe.</p>
     
    </script>
  </body>
</html>

But probably want something like:

    <script src="public/client.js"></script>
  </body>
</html>
1 Like

Hey!
Sorry for the late reply. I tried loading the client.js file as you suggested in the index.html file, but to no avail. The directory holding the .js file was actually “public/js/client.js”, but even with that fixed, I still have no display. Do you haven any potential idea what could be the problem here?
Thanks again!

Just to confirm - you have the Power-Up enabled on a board?

When you load the board, open your browser’s web developer console. Do you see any error messages? Anything failing to load?

If you update your client.js to include a console.log, do you see that fire?