Unable to call search by account

It seems like you can no longer search by account using the rest API. I’ve tried numerous different account numbers and all of them seem to return the same error, I’ve double checked and all the account numbers that I have used definitely still exist and have been applied to their related issues etc. We had been using this feature successfully for several years prior to now. Can’t seem to find anything in the API documentation that says this feature would be removed, does anyone have any ideas as to what is happening here?

URL: https://csamltd.atlassian.net/rest/api/2/search?jql=account=TWM1OC1598&fields=key,summary,description,parent,timetracking

{“errorMessages”:[“The option ‘TWM1OC1598’ for field ‘account’ does not exist.”],“warningMessages”:[]}

Make sure that the query string is valid - In the above case - account=TWMC10C1598 should be account%3DTWMC10C1598 .

The error message seems to be more that SURCOC1381 is an option on a field and the search index is having an issue. Can you try reindexing the instance?

Yeah sorry I’ve updated the error message to what it should be, I’m continuing to get the same error when changing = to %3

What type of field is account? Are the multiple fields named account? If account is a select-ish field - are the options populated?

There is one field held against each record in jira, you can find the account key by going into the account tab. Each issue in jira can have an account assigned to it.
The query string was previously working perfectly, something must have changed in the API but i’m unable to find the information that details it :confused:

Ok so I was able to recreate this error message locally using jira 7.2.4.

Can you check the Account custom field and what the type is? My guess is that it’s a select field of some kind.

If it is a select field, go into the options for it and verify that the values you’re expecting are there:

The error you’re getting would indicate that they are not valid options for a select field.

Hi @callum,

Accounts are not a built-in field in JIRA. Perhaps this field is coming from Tempo Timesheets and was affected by the recent migration? https://support.tempo.io/hc/en-us/articles/115000978208

Dave