Unable to complete confluence helloworld macro plugin tutorial

Hi there. I am working through this tutorial: macro/https://developer.atlassian.com/server/framework/atlassian-sdk/create-a-confluence-hello-world-macro/

I run atlas-create-confluence-plugin and call atlas-run and when I go to localhost___1990 I get this tomcat 404 page:

java and atlassian sdk versions:

Z:\Documents\atlassian-plugin\macroPlugin\myConfluenceMacro>java -version
java version "1.8.0_261"
Java(TM) SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.261-b12, mixed mode)

Z:\Documents\atlassian-plugin\macroPlugin\myConfluenceMacro>javac -version
javac 1.8.0_261

Z:\Documents\atlassian-plugin\macroPlugin\myConfluenceMacro>echo %JAVA_HOME%
C:\Progra~1\Java\jdk1.8.0_261

Z:\Documents\atlassian-plugin\macroPlugin\myConfluenceMacro>atlas-version

ATLAS Version:    8.0.16
ATLAS Home:       C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.16
ATLAS Scripts:    C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.16\bin
ATLAS Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.16\apache-m
aven-3.5.4
AMPS Version:     8.0.2
--------
[INFO] Project POM found
Executing: "C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.16\apache-maven-3
.5.4\bin\mvn.cmd" --version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-8
.0.16\apache-maven-3.5.4/conf/settings.xml
Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-17T11:33:1
4-07:00)
Maven home: C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.16\apache-maven-3
.5.4\bin\..
Java version: 1.8.0_261, vendor: Oracle Corporation, runtime: C:\Progra~1\Java\j
dk1.8.0_261\jre
Default locale: en_CA, platform encoding: Cp1252
OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"

I have tried it on windows 7, ubuntu 20.04, ubuntu 16.04, and windows 8 (all different machines as well) with oracle jdk 8 and openjdk 8.
I was able to complete the Jira plugin tutorial.

Posting the full log bugs the character limit, but I can do it in the comments. Some pertinent parts I have noticed are:

[INFO] [talledLocalContainer] INFO: Server startup in 16441 ms
[INFO] [talledLocalContainer] Tomcat 9.x started on port [1990]
[INFO] confluence started successfully in 53s at http://localhost:1990/confluence
[INFO] Type Ctrl-C to shutdown gracefully
[INFO] [talledLocalContainer] 2020-08-04 01:52:45,792 FATAL [main] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
[INFO] [talledLocalContainer] 2020-08-04 01:52:45,821 WARN [main] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
[INFO] [talledLocalContainer] 2020-08-04 01:52:45,824 INFO [main] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
[INFO] [talledLocalContainer] 2020-08-04 01:52:45,844 ERROR [main] [com.atlassian.threadlocal.BruteForceThreadLocalCleanup] logErr Thread[main,5,main] created a ThreadLocal with key of type [org.springframework.core.NamedThreadLocal] (value [Prototype beans currently in creation]) and a value of type [null] (value [null]). This will be cleaned up
[INFO] [talledLocalContainer] 2020-08-04 01:52:45,844 ERROR [main] [com.atlassian.threadlocal.BruteForceThreadLocalCleanup] logErr Thread[main,5,main] created a ThreadLocal with key of type [org.apache.log4j.helpers.ThreadLocalMap] (value [org.apache.log4j.helpers.ThreadLocalMap@4178074f]) and a value of type [null] (value [null]). This will be cleaned up
[INFO] [talledLocalContainer] Aug 04, 2020 1:52:45 AM org.apache.catalina.loader.WebappClassLoaderBase clearReferencesJdbc
[WARNING] [talledLocalContainer] WARNING: The web application [confluence] registered the JDBC driver [org.h2.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak

This issue is talked about here https://jira.atlassian.com/browse/CONFSERVER-60095?error=login_required&error_description=Login+required&state=3b8b01d7-7a19-498b-8f99-3c2fe5ac4674&state=00a83304-726f-451e-bd8e-aeb2c6d55c4a

I think it is a problem that the default version of confluence installed by atlas-run is incompatible with the most recent version of the JDK. I would suggest updating the confluence version to 7.x or adding a warning in the tutorial in the section about installing the JDK.