Uninstall forge client with npm (OS crash on Mac)

Hi there,

I recently installed the forge client on my Mac to have a look at it and do the tutorial for building a cloud app. Unfortunately, after running through the first steps successfully, my Mac is crashing all the time whenever I run any forge command (it all started after running forge tunnel). It restarts directly afterwards, however this is very annoying and I can’t really work with it. I am on the latest Mac OS version 11.0.1, maybe that is related to the issues im facing.

I now wanted to uninstall @forge/cli and install it again with nom. However, I didn’t find a way to uninstall it. Can anyone help with that? I didn’t find anything on the internet how to uninstall forge with npm.

Thanks in advance.

Cheers,
Jonas

The command to uninstall an npm package its generally just like the install command except you say uninstall. So it would look like this:

npm uninstall -g @forge/cli

Regarding your system crashing when running forge commands perhaps someone from Atlassian can help address that.

Hey @ij-s, if Forge is Crashing when you run the forge tunnel command then that might be a Docker issue since forge uses Docker for tunnelling. Could you perhaps share your relevant crash logs with us?

1 Like

Hi @ij-s,

Do you mind sharing with us your Mac’s year/model?

Apparently, the new Mac OS 11 is causing some unexpected crashes/freezes when running on older Macs (pre 2015).

Thanks, the uninstall command worked. I successfully uninstalled forge and will try it again with a fresh install. If the crash comes up again I will share the logs here.

My Mac is a MacBook Pro from 2019, so it don’t seems to be related to the issue with older Macs

1 Like

I now reinstalled forge and tried it again. Unfortunately, the OS crashed again. Here are the log files of the crash, maybe they help to identify what is the problem.

panic(cpu 6 caller 0xffffff8008abfb71): assertion failed: (MBUFQ_EMPTY(&cfq->q_mq) && cfq->q_start == cfq->q_end) || (!MBUFQ_EMPTY(&cfq->q_mq) && cfq->q_start != cfq->q_end), file: /AppleInternal/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-7195.50.7/bsd/net/content_filter.c, line: 1089
Backtrace (CPU 6), Frame : Return Address
0xffffffb0b251b6f0 : 0xffffff80082bc66d 
0xffffffb0b251b740 : 0xffffff80083ff073 
0xffffffb0b251b780 : 0xffffff80083ef6aa 
0xffffffb0b251b7d0 : 0xffffff8008261a2f 
0xffffffb0b251b7f0 : 0xffffff80082bbf0d 
0xffffffb0b251b910 : 0xffffff80082bc1f8 
0xffffffb0b251b980 : 0xffffff8008abee1a 
0xffffffb0b251b9f0 : 0xffffff8008abfb71 
0xffffffb0b251ba00 : 0xffffff80086adcfe 
0xffffffb0b251ba40 : 0xffffff80086ae008 
0xffffffb0b251bbd0 : 0xffffff80086ac4ef 
0xffffffb0b251bc20 : 0xffffff80086a921c 
0xffffffb0b251bc90 : 0xffffff800882ecf9 
0xffffffb0b251bce0 : 0xffffff80088a8c20 
0xffffffb0b251be00 : 0xffffff800887d4c8 
0xffffffb0b251be30 : 0xffffff8008877e35 
0xffffffb0b251bee0 : 0xffffff8008877c47 
0xffffffb0b251bf40 : 0xffffff8008969ceb 
0xffffffb0b251bfa0 : 0xffffff80082621f6 

Process name corresponding to current thread: com.symantec.mes.systemextension
Boot args: chunklist-security-epoch=0 -chunklist-no-rev2-dev chunklist-security-epoch=0 -chunklist-no-rev2-dev

Mac OS version:
20B29

Kernel version:
Darwin Kernel Version 20.1.0: Sat Oct 31 00:07:11 PDT 2020; root:xnu-7195.50.7~2/RELEASE_X86_64
Kernel UUID: 84C6DC45-6B02-335F-9439-5D2A9BC385A4
KernelCache slide: 0x0000000008000000
KernelCache base:  0xffffff8008200000
Kernel slide:      0x0000000008010000
Kernel text base:  0xffffff8008210000
__HIB  text base: 0xffffff8008100000
System model name: MacBookPro15,4 (Mac-53FDB3D8DB8CA971)
System shutdown begun: NO
Hibernation exit count: 30

System uptime in nanoseconds: 12487438094405
Last Sleep:           absolute           base_tsc          base_nano
  Uptime  : 0x00000b5b754fd406
  Sleep   : 0x00000b50615f038a 0x00000001024a4c76 0x000009de3e4ae866
  Wake    : 0x00000b506dcc7ab7 0x0000028861cf4bba 0x00000b506c899122
last started kext at 12441035587694: >usb.IOUSBHostHIDDevice	1.2 (addr 0xffffff800b198000, size 40960)
last stopped kext at 12084230781852: >usb.!UUserHCI	1 (addr 0xffffff7fa7def000, size 98304)