Unresolveable build extension: Plugin com.atlassian.maven.plugins:maven-jira-plugin:6.3.15 - while building the Jira apps using the project-blueprint plugin module

Error Message - Unresolveable build extension: Plugin com.atlassian.maven.plugins:maven-jira-plugin:6.3.15

Problem Description : *We are creating a custom project template as per our business requirement using project-blueprint plugin module. Source Code has been downloaded from the Git repository as per process given process here - https://developer.atlassian.com/server/jira/platform/creating-a-project-template/

The development environment is setup with required software and access permissions. While trying to build the source from Eclipse ‘maven-jira-plugin’ dependency is failing continuously.*

Dependency - pom.xml
<plugin>
<groupId>com.atlassian.maven.plugins</groupId>
<artifactId>maven-jira-plugin</artifactId>
<version>${amps.version}</version>
<extensions>true</extensions>
<configuration>

Error snapshot is also attached.

This is stopping us from building the source code. Can somebody help with possible solution?

Hello @bhushan.kolambe,

Does it work fine if you run atlas-run or atlas-package in the command line instead of building in the IDE? If it does, it has something to do with how the project was imported to Eclipse.

Also, what version of the SDK and AMPS are you using? Kindly run atlas-version in the command line to get those info.

Cheers,
Ian

Thanks Iragude for your response.
We ran using atlas-run and atlas-package command from command line as well and got the same issue. Please see the snapshot attached here.

Version details -
ATLAS Version: 8.0.7
AMPS Version: 8.0.0

We tried reaching JIRA support as well. JIRA support distanced itself saying it is outside the scope of support offering.
Any other work around, please? Thank you.

Regards,
Bhushan

Not sure if this is the same issue we had when moving to SDK 8, but the artifact co-ordinates for the amps Maven plugins changed with this version, presumably to comply with maven naming convention (the form maven--plugin being reserved for official plugins like maven-compiler-plugin). And for running SDK 8, I believe you must also use an 8.x version of the maven plugin.
If you look at https://m2proxy.atlassian.com/maven-external/com/atlassian/maven/plugins/maven-jira-plugin/ you’ll see the versions stop at 6.x. For 8.x onwards, see https://m2proxy.atlassian.com/maven-external/com/atlassian/maven/plugins/jira-maven-plugin/

For AMPS >=8.x, try changing your plugin coordinates from maven-jira-plugin to jira-maven-plugin:

com.atlassian.maven.plugins
jira-maven-plugin

Edit: Though looking at it again, the coords look valid even though they do not match your SDK. Could be just be a regular Maven dependency resolution problem. Can you actually reach the artifact URL from your browser ( https://maven.atlassian.com/repository/public/com/atlassian/maven/plugins/maven-jira-plugin/6.3.15/maven-jira-plugin-6.3.15.pom)? Are you sure that access to the repo doesn’t require you to go through/configure a corporate proxy (your browser could be using one even though Java/Maven isn’t).

Thank you audun.roe for your response.

Yes, we already tried with that option including changing the repo name like maven-jira , jira-maven but still no luck.
I must say we tried all the option changing the version of S/W , compatibility and other stuff but still build is falling with old issue only.
This is the Enterprise JIRA version we are using.

May I ask if it is possible for you/anyone from the community to take a remote session to check this issue and provide any help?
Thank you.

Interesting, I have not encountered this before. Have you tried creating a new sample app by calling atlas-create-jira-plugin and then calling atlas-run inside the newly created project to see if it works and if you are able to connect to the maven repo? I want to isolate the scenario wherein you’re behind a firewall and the credentials aren’t setup in settings.xml of Maven.

1 Like

Thank you for your response, iragudo,.

The issue was with the credentials in settings.xml. With correct credentials, we are now able to download all the required dependencies and code is also build successfully.

Thank you and thank you all for your help with this issue.
Have a good day!

1 Like

You’re welcome and happy coding :wink: