Upgrade from 7.xx version plugin to 8.xx

Dear community, I have recently updated version of the plugin to target our prod JIRA version which is 8.2.5. I only changed in pom version of the jira and nothing else as all components I use I follow newest AUI guides.
I tried to follow the guide: https://docs.atlassian.com/aui/8.0.0/docs/upgrades/aui-8.html?_ga=2.165692285.294267926.1575449209-1114402002.1548675289
But it did not help…
After the update I get a lot of deprecated messages even though I do not use those components:

com.atlassian.auiplugin:aui-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:pinnablenavigator")
2019-12-06 09:47:21,059 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-ui-sortable" has been deprecated since 8.0.0 and will be removed in 9.0.0. (required by "com.atlassian.jira.jira-projects-plugin:pinnablenavigator")
2019-12-06 09:47:21,059 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-spin" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-spinner instead. (required by "com.atlassian.jira.jira-projects-plugin:pinnablenavigator")
2019-12-06 09:47:21,059 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-ui" has been deprecated since 8.0.0 and will be removed in 9.0.0. jQuery UI is a painful set of code to pull in and depend upon since it fundamentally relies upon mutating a shared global object and encourages implicit dependencies that are hard to trace. AUI or AtlasKit components should be used instead. (required by "com.atlassian.jira.jira-projects-plugin:pinnablenavigator")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:project-page")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:ajs-underscorejs-amd-shim" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use jira.webresources:underscore-1.8.3 instead. (required by "com.atlassian.jira.jira-projects-plugin:feature-discovery")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:ajs-underscorejs-amd-shim" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use jira.webresources:underscore-1.8.3 instead. (required by "com.atlassian.jira.jira-projects-plugin:jira-projects-backbone")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:ajs-underscorejs-amd-shim" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use jira.webresources:underscore-1.8.3 instead. (required by "com.atlassian.jira.jira-projects-plugin:marionette")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:ajs-underscorejs-amd-shim" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use jira.webresources:underscore-1.8.3 instead. (required by "com.atlassian.jira.jira-projects-plugin:backbone-paginator")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-spin" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-spinner instead. (required by "com.atlassian.jira.jira-projects-plugin:sidebar-project-shortcuts")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:dialog2" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:sidebar-project-shortcuts")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:sidebar-project-shortcuts")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:project-subpages-soy")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:abstract-list-page")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:release-page-assets")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-ui-sortable" has been deprecated since 8.0.0 and will be removed in 9.0.0. (required by "com.atlassian.jira.jira-projects-plugin:release-page-assets")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "jira.webresources:jquery-spin" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-spinner instead. (required by "com.atlassian.jira.jira-projects-plugin:release-page-init")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:components-page-assets")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:sidebar-header-soy")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:sidebar-soy")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:summary-page-summary-bar-resources")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:summary-page-priority-summary-resources")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:summary-page-priority-summary-test-resources")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.jira.jira-projects-plugin:summary-page-assignee-summary-resources")
2019-12-06 09:47:21,060 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:unlicensed-project-type")
2019-12-06 09:47:21,061 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:aui-experimental-soy-templates" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:soy instead. (required by "com.atlassian.jira.jira-projects-plugin:project-admin-soy")
2019-12-06 09:47:21,061 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:inline-dialog" has been deprecated since 5.0.0 and will be removed in 9.0.0. Use com.atlassian.auiplugin:aui-inline-dialog2 instead. (required by "com.atlassian.crowd.embedded.admin:web-resources")
2019-12-06 09:47:21,061 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:template" has been deprecated since 8.0.0 and will be removed in 9.0.0. We recommend use of other open-source templating engines, such as `lit-html` or `react`. If you cannot do without this templating function, it is available as its own Node package: `@atlassian/aui-template`. (required by "com.atlassian.crowd.embedded.admin:web-resources")
2019-12-06 09:47:21,061 http-nio-2990-exec-2 WARN admin 587x8564x1 1xtkrn3 0:0:0:0:0:0:0:1 /secure/AppConfigurationAction.jspa [webresource] [DEPRECATED] "com.atlassian.auiplugin:ajs-backbone" has been deprecated since 8.0.0 and will be removed in 9.0.0. Backbone should be bundled by and internally scoped in individual products or plugins. (required by "com.atlassian.analytics.analytics-client:event-report")