Upgrading Jira version from 7 to 8 in Jira plugin causes multiple DEPRECATED warnings for web resources I don't even use

Hi Jira Community,

I tried updating a Jira Plugin from version 7.x.x to the version we use in production which is 8.16.1. I’ve noticed that I get a lot of deprecation warnings looking like this:

2021-05-25 13:16:25,312 http-nio-2990-exec-2 WARN anonymous 796x2x2 - /rest/gadgets/1.0/g/feed [webresource] [DEPRECATED] "jira.webresources:underscore-1.5.2" has been deprecated since 8.0.0 and will be removed in 9.0.0. Use jira.webresources:underscore-1.8.3 instead. (required by "com.pyxis.greenhopper.jira:gh-analytics-tracker")

I tried recreating it by creating an empty project skeleton. The warnings showed immediately, even if I don’t have any code or scripting in my project.

my web ressource looks like this:

<web-resource key="test-resources" name="test Web Resources">


<resource type="download" name="test.css" location="/css/test.css"/>

<resource type="download" name="test.js" location="/js/test.js"/>

<resource type="download" name="images/" location="/images"/>



and I’ve added the 3.6.0 version of atlassian-plugins-webresource in my POM:







The only thing I found about this is AUI 8 upgrade guide which doesn’t help, since there are no web resources to upgrade in the project.

1 Like

I also get a lot of deprecation warnings like you do. I just ignore them by now. There are also lots of front end warnings in the developer console as well. I guess it is just the way it is.

1 Like