Use Confluence editor in my plug in

Hi all,

I want to use Confluence editor as an editor in my add-on but I don’t know how.
Could you please help me?

Thanks,
Martin

Hi @tdmit2016,

Are you referring to the app Confluence Source Editor or the Page editor of Confluence? Like extend it on your app? Can you provide more context on this, like what you want to do.

Cheers,
Anne Calantog

1 Like

Thanks @acalantog,

I read this link https://confluence.atlassian.com/doc/preparing-for-confluence-6-8-943980256.html
and would like to use the Confluence editor or tinymce in my plugin.
But I don’t know how. Could you please help me?

Thank you very much!

Hi @tdmit2016,

Is this the part you were referring to:

TinyMCE upgrade for the Confluence editor
We have been working on upgrading TinyMCE from version 3 to version 4, and are pleased to say that the upgrade is now in a state where you can start testing it with your add-ons. If you have an add-on that interacts with the editor in any way, we strongly recommend you begin testing your add-on with the upgraded editor as soon as possible. We don’t have a set release date for the upgrade, but will target the earliest version where such an upgrade can take place. We hope that there will be minimal if any changes required to add-ons, but there might be some things we do not expect. In the worst case the upgrade will ship in Confluence 7.0 where add-on changes would be required, but it should be expected to ship sooner.

Please know that that documentation refers on how you could prepare for the new release as an app developer. It enables you to test your existing apps with the upgrade in TinyMCE, and mostly that’s it.

Do you want to spawn your own editor in Confluence? What does you app do and why does it need its own editor?

Cheers,
Anne Calantog