WebItem url not work on jira service desk

Hi. I am making app for jira cloud and have webItems block with this url parameter ‘url’ => ‘/projects/{project.key}?selectedItem=com.example.myaddon__connect-provided-link-to-panel’. It’s work on most projects type such as the kanban board or the scrum board and redirect on my page but does not work on service desk board. After click by my link on service desk board it’s only reload current page.

Please tell me how can I solve this problem


Same here.
I think jiraProjectPages might solve my problem, but I don’t know whether it is correct.

1 Like

Hi all,

JSD recently moved to a new SPA framework that sounds like has broken the links. Can you tell me where these webitems are being rendered?

1 Like

Hi @BrianNguyen,
In my case, I’m using “location”: “jira.project.sidebar.plugins.navigation”.

Hmm that should be working. However the URL may have changed from /projects/<projectkey> to /jira/servicedesk/project/<projectkey>. Would this impact your addon?

Hi @BrianNguyen,

Do you suggest the below fix?


              "location": "jira.project.sidebar.plugins.navigation",
              "url": "/projects/{project.key}?selectedItem=com.example.myaddon__connect-provided-link-to-panel",


              "location": "jira.project.sidebar.plugins.navigation",
              "url": "/jira/servicedesk/project/<projectkey>?selectedItem=com.example.myaddon__connect-provided-link-to-panel",

My app does not distinguish project types (Business/Software/ServiceDesk), so I think “/jira/servicedesk/project” may not work on Business/Software projects correctly.

Do you have any documentation or announcement about the JSD framework changed?

Thanks in advance.

Same bug with my addon which is no more accessible from Service Desk project. Could you please fix this ?

1 Like

Hi all,

Could you please, share the JSON snippet you are using to declare the webItems module within the atlassian-connect.json file? That would help me to reproduce it on my own environment. Make sure that you don’t share anything private.

In addition, I would like to know if this feature used to work for you previously on Service Desk on your instance.

@hirota.takayuki, have you tried to use jiraProjectPages instead of webItems?

1 Like

Hi @AdolfoEloy,

I don’t know when the webItem has broken, but I believe our app worked correctly previously (since 3 years ago).
Our team tried jiraProjectPages and confirmed it works, but I would like to know the JSD behaviour changes. I think the change of URL may impact customers and marketplace apps.

Sample snippet for webItems and webPanels is here:

        "webItems": [{
            "key": "connect-provided-link-to-panel",
            "location": "jira.project.sidebar.plugins.navigation",
            "context": "product",
            "icon": {
                "width": 20,
                "height": 20,
                "url": "/images/myaddon.svg"
            "name": {
                "value": "My Menu"
            "url": "/projects/{project.key}?selectedItem=com.example.myaddon__connect-provided-link-to-panel"
        "webPanels": [{
            "key": "connect-web-panel",
            "url": "/panel.html?projectKey={project.key}",
            "location": "com.example.myaddon__connect-provided-link-to-panel",
            "name": {
                "value": "My Web Panel"
1 Like

Hi @hirota.takayuki,

Thanks for the details provided. I added a similar webItem on my local environment and it’s apparently working at my side. I noticed some blips where I had to click on the webItem again so the content could be rendered, but this might be just something related to my environment.

In your case you are referencing a webPanel from a webItem, right? I just tried with a webItem referencing a serviceDeskQueues. I’ll try with a webPanel too and I will let you know from my next findings.

Could you please, let me know more details about what’s the actual behaviour you are facing with your app? Does the panel just remains empty?

Hi @AdolfoEloy,

Yes, I’m referencing my webPanel page from my webItem in my case.

The webPanel page works correctly in Business/Software projects, but does not work in Service Desk classic projects. Issues or Queues page instead of our add-on page is displayed.

Thanks for your cooperation.


1 Like

Hey everyone, we are working on fixing this now - please watch https://jira.atlassian.com/browse/JSDCLOUD-9206 for updates.


@hirota.takayuki and @otonomiz we have fixed the issue that we believe is impacting your addon. Please let us know if this is still an issue for you and we will follow up as soon as we can.


Hi @BrianNguyen, I confirmed our problem is fixed. Thank you for quick fix!

1 Like

IIRC you should have an instance of JiraHelper in the context of the Atlassian-Plugin.xml file. This variable is named ‘helper’. Thus, you should be able to use $helper.request.contextPath in order to obtain the context path, if it exists.