17 Aug 2021 - Automatic resizing for custom UI apps

Custom UI apps can now resize automatically to fit their content. Deploy your app with the latest version of @forge/cli and omit the viewportSize property from the module in the app’s manifest.

You can add viewportSize to a module to opt-out of this behavior.

Run npm install @forge/cli@latest on the command line to install the latest version of @forge/cli .

12 Likes

Hi @PeterYu - does this apply to Forge Confluence macros as well?

2 Likes

Yes, it applies to Forge Confluence macros.

2 Likes

Hi @PeterYu , thanks for this feature!

Is there a certain minimum height defined?

I tried it with 2 simple buttons (from @atlaskit/button , height ~34px) and in total it took some more space.
2021-08-18 Confluence

BR,
Franz

1 Like

Awesome! This was a really important feature! :slight_smile:

1 Like

Great improvement!

Sadly, the “Allow access” button is not visible anymore in Confluence macros. It reproducible with a simple hello world macro and a permission scope like “read:confluence-user”.

4 Likes

We stumbled across the same issue. While this works great for our IssueGlance in Jira, a user can not allow access solely by using a Confluence macro. That is too bad as this feature is especially important for dynamic page content. :frowning:

Can we expect a fix for that? :slight_smile:

Julian

2 Likes

Yes, some additional height gets added as a buffer in case an app has overflowing content and requires a horizontal scrollbar. The height calculation is unable to factor in the height of the scrollbar, and so we get some undesirable behavior if the buffer isn’t added.

cc: @TilmanSchweitzer

Thanks for letting us know about this bug. The team will work on a fix ASAP. In the meantime you can add viewportSize to your macro module so that users can access the “Allow access” button.

@JulianWolf @TilmanSchweitzer

The bug where Confluence macros are not visible should be fixed now.

1 Like

Amazing work guys but I think this bug I reported earlier today is related, can you please take a look? It’s a huge blocker for us.

https://ecosystem.atlassian.net/secure/RapidBoard.jspa?rapidView=749&projectKey=FRGE&modal=detail&selectedIssue=FRGE-358

@Abdessamad Thanks for raising this, we will investigate it.

2 Likes

@Abdessamad I saw in the ticket you referenced that you indicated the issue was fixed however I am still seeing the problem. Are you setting a viewport size for your modal? I’m having a very similar sizing issue with my modals despite them being configured as xlarge in the manifest. These were working fine but stopped working about the time the dynamic sizing work came out.

@jeffryan, the bug in the issue was actually fixed, setting a viewport size currently only affects your modal’s width. and the height depends on the content of your modal. I think setting your modal’s content to a fixed height should probably be a quick fix in your case.

1 Like