403 error when using POST call for issue transition

I am getting a 403 issue when using the API Transition issue
POST /rest/api/3/issue/{issueIdOrKey}/transitions) endpoint

This is for my Connect on Forge App.
atlassian-connect.json permissions are - "scopes": [ "read", "act_as_user", "write" ]

The Forge manifest has the below permissions

scopes: [ "read:connect-jira" , "write:issue:jira"]

403 Error

Hi @ajay,

Does this work when adding the write:issue.property:jira to the Forge manifest?

According to the doc, the following scopes are required:
OAuth scopes required : write:issue:jira , write:issue.property:jira

While you are at this, you might want to switch to the OAuth scopes: write:jira-work instead. I know that the documentation has not been updated yet but the deprecation has been stopped.
For reference:


Hi @ccurti ,

I tried modifying the manifest by adding write:issue.property:jira as well using the write:jira-work with no success. I still get 403 as the response code :pensive: