404 error on i18n files



Hi all

I am going through the CLoud plugin tutorials. I am currently trying to add internationalization as described here:

I am using the Hello World example and created a folder “i18n”. In there I placed two files

  • de-DE.json
  • en-US.json

Both, have the same conent except of the language strings:

   "bg-color-macro.name": "Color",
   "bg-color-macro.desc": "Allow users to add a background colour around selected content.",
   "bg-color-macro.param.color.label": "Color",
   "bg-color-macro.param.color.desc": "Enter the color in HEX",
   "bg-color-macro.param.style.label": "CSS Styles",
   "bg-color-macro.param.style.desc": "Add more CSS styles here"

In atlassian-connect.json I added:

   "translations": {
      "paths": {
         "de-DE": "/i18n/de-DE.json",
         "en-US": "/i18n/en-US.json"

When running “npm start” I get the following error:

GET /i18n/en-US.json 404 2.461 ms - 154
GET /i18n/de-DE.json 404 1.168 ms - 154
Registered with host at https://johndoe-dev.atlassian.net/wiki
Add-on is disabled on https://johndoe-dev.atlassian.net/wiki. Enable manually via upm

What am I missing? Why the 404 even though the files exist?

Thanks and best regards,


Hi all
I was able to solve this by moving the “i18n” folder into the “public” directory of the demo code and then referring to them in atlassian-connect.json like this:

   "translations": {
      "paths": {
         "de-DE": "i18n/de-DE.json",
         "en-US": "i18n/en-US.json"

Hope that helps others running into this problem as well.

Best regards,