Add-on installed but doesn't show up for user

Hi Atlassian developers,

I’m new here so maybe I’m not aware of some basics in Atlassian add-on development.

I tried to develop my first macro add-on for Confluence Cloud. So I followed the tutorial here and created my cloud development instance. The example hello-world add-on is built and installed successfully - I can see it in the Manage add-ons page in my development site. But when I tried to use the new macro in a confluence page by typing {hello, or looking for it in the macro browser, I can not find it!

I also uploaded the example hello-world add-on to Heroku and tried it, but didn’t get any luck. Here is the App Descriptor.

Did I missing anything?

It’s highly appreciated if anyone can point out what’s the problem.

Thanks.

2 Likes

Can you provide a screenshot of the macro browser showing where it doesn’t show up?

Might be because of this: https://jira.atlassian.com/browse/CONFCLOUD-58280

Workaround: Clear your browser cache, or maybe try opening your browser dev tools and disabling the cache. That might help you continue on while Atlassian are fixing this issue.

3 Likes

The workaround works!

Thanks for your information. Hope this issue get fixed soon.

Cheers,

1 Like

This is a problem that can cause a bad first experience for someone who is trying a new plugin.

I have an app that got a 1-star review because a user ran into this and got frustrated.

https://jira.atlassian.com/browse/CONFCLOUD-58280 is in progress but it has been slow going. If this issue affects you please upvote the bug.

1 Like