All request urls set in atlassian-connect.json return [object%20Object]

I have the following adminPages url setup in my atlassian-connect.json. This was working in my test cloud instance previously, but I tried refreshing the page and now the request url comes in as
/route/plugin/1.0/[object%20Object] . I am not sure what is causing this issue

"adminPages": [
        {
          "url": "/route/plugin/1.0/admin",
          "name": {
            "value": "Settings",
            "i18n":  "settings.name"
          },
          "key": "admin-settings"
        }
      ],

@adisa.craig,

Are you using one of the Atlassian frameworks like Atlassian Connect Express or Atlassian Connect Spring Boot?

Yes I am using Atlassian Connect Express @ibuchanan

@ibuchanan After a bit more debugging, it seems the issue is coming from within the template. I have the following script tags in my .hbs template

<script type="text/javascript" src="{{furl '/dist/admin/bundle.js'}}"></script>

when the template loads in Confluence cloud the script tag loads as

<script type="text/javascript" src="[object%20Object]"></script>

If I remove the furl and the open and closing braces it works. However this furl syntax worked previously.

My guess would be something is broken in the furl function within handlebars.

Alexey has a great article on this topic. Check this out: https://community.atlassian.com/t5/Marketplace-Apps-Integrations/atlassian-connect-express-furl-error/ba-p/1673379

1 Like

As a warning, static-expiry - npm is not maintained, and had no release since 6 years. Security issues are not fixed.

1 Like

This alternative hasn’t been published in a while either, but has at least been updated to fix npm audit warnings.