Always timeout during forge deploy

Always failed with this error when deploying forge app.
This is my first time deploying forge app.

>forge deploy

Running forge lint...
No issues found.


Error: request to https://api.atlassian.com/graphql failed, reason: connect ETIMEDOUT 18.136.214.14:443

Have tried using 2 different networks but with same result.
Have tried relogin from forge-cli with same result.
I can open GraphQL Gateway just fine on the browser (< 1s).

Can someone help me?

Windows 10
Node 14.17.6
Forge 2.0.1, Forge 2.0.0 same result

Hey @Ray. Looks like your terminal can’t access api.atlassian.com. Could you please check if your browser has any special proxy settings that allow reaching to the outer internet? Also, could you please run something like curl -v https://api.atlassian.com/graphql?

After trying via terminal, it timed out intermittently.
After trying again via browser with incognito / private mode, it also timed out intermittently.

>curl -v https://api.atlassian.com/graphql
*   Trying 18.136.214.12...
* TCP_NODELAY set
* connect to 18.136.214.12 port 443 failed: Timed out
*   Trying 18.136.214.14...
* TCP_NODELAY set
* connect to 18.136.214.14 port 443 failed: Timed out
*   Trying 18.136.214.13...
* TCP_NODELAY set
* Connected to api.atlassian.com (18.136.214.13) port 443 (#0)
* schannel: SSL/TLS connection with api.atlassian.com port 443 (step 1/3)
* schannel: checking server certificate revocation
* schannel: sending initial handshake data: sending 182 bytes...
* schannel: sent initial handshake data: sent 182 bytes
* schannel: SSL/TLS connection with api.atlassian.com port 443 (step 2/3)
* schannel: failed to receive handshake, need more data
* schannel: SSL/TLS connection with api.atlassian.com port 443 (step 2/3)
* schannel: encrypted data got 3049
* schannel: encrypted data buffer: offset 3049 length 4096
* schannel: sending next handshake data: sending 126 bytes...
* schannel: SSL/TLS connection with api.atlassian.com port 443 (step 2/3)
* schannel: encrypted data got 242
* schannel: encrypted data buffer: offset 242 length 4096
* schannel: SSL/TLS handshake complete
* schannel: SSL/TLS connection with api.atlassian.com port 443 (step 3/3)
* schannel: stored credential handle in session cache
> GET /graphql HTTP/1.1
> Host: api.atlassian.com
> User-Agent: curl/7.55.1
> Accept: */*
>
* schannel: client wants to read 102400 bytes
* schannel: encdata_buffer resized 103424
* schannel: encrypted data buffer: offset 0 length 103424
* schannel: encrypted data got 1693
* schannel: encrypted data buffer: offset 1693 length 103424
* schannel: decrypted data length: 734
* schannel: decrypted data added: 734
* schannel: decrypted data cached: offset 734 length 102400
* schannel: encrypted data length: 930
* schannel: encrypted data cached: offset 930 length 103424
* schannel: decrypted data length: 901
* schannel: decrypted data added: 901
* schannel: decrypted data cached: offset 1635 length 102400
* schannel: encrypted data buffer: offset 0 length 103424
* schannel: decrypted data buffer: offset 1635 length 102400
* schannel: schannel_recv cleanup
* schannel: decrypted data returned 1635
* schannel: decrypted data buffer: offset 0 length 102400
< HTTP/1.1 200 OK
< server: envoy
< cache-control: no-cache, no-store, max-age=0, must-revalidate
< Content-Type: text/html
< Strict-Transport-Security: max-age=315360000; includeSubDomains; preload
< access-control-expose-headers: x-request-id, x-trace-id
< Date: Mon, 20 Sep 2021 02:25:00 GMT
< x-request-id: 71dc90bed61dcae5
< expires: 0
< pragma: no-cache
< X-XSS-Protection: 1; mode=block
< x-envoy-upstream-service-time: 16
< accept-ranges: bytes
< X-Content-Type-Options: nosniff
< Connection: keep-alive
< X-Trace-Id: 71dc90bed61dcae5
< x-frame-options: DENY
< Expect-CT: report-uri="https://web-security-reports.services.atlassian.com/expect-ct-report/global-proxy", enforce, max-age=86400
< referrer-policy: no-referrer
< Content-Length: 901
<
<!doctype html><html lang="en" dir="ltr"><head><meta charset="UTF-8"/><meta name="viewport" content="width=device-width,initial-scale=1,shrink-to-fit=no"/><title>GraphQL Gateway</title></head><body><style>body {
        padding: 0;
        margin: 0;
        min-height: 100vh;
      }
      #root {
        height: 100vh;
      }</style><div id="root"></div>
<script>
    function loadEnvScript() {
            if (window.location.href.includes("api-private.atlassian") || window.location.href.includes("api.atlassian")) {
                document.write('<script src="https://graphql-gateway-static--app.ap-southeast-2.dev.public.atl-paas.net/prod-main.js"><\/script>');
            } else {
                document.write(`<script src="https://graphql-gateway-static.ap-southeast-2.dev.public.atl-paas.net/stg-main.js"><\/script>`);
            }
    }
    loadEnvScript();
</script>

</body></html>* Connection #0 to host api.atlassian.com left intact

Browser was set to use system proxy settings and system was using company VPN.
But my friends are not getting any timeout even though they use the same company VPN.
It must be an issue with my 2 networks.
Finally tried using 3rd network (mobile network), and it worked.

Guess i will have to switch network first before deploying then, not really a problem.
Thanks for pointing me in the right direction @Dmitrii .