api.asUser().requestJira calls from Confluence don't work anymore?

Has something changed in the last release of forge regarding cross-app access? Last Thursday this code worked fine, but now it doesn’t give any response - just an eternal timeout.

    getCustomFieldValue = async(config, fieldId, valueName) => {
        let projectKey = config.projectKey
        let issueType = config.issueTypeId
        const response = await api.asUser().requestJira(route`/rest/api/2/issue/createmeta?projectKeys=${projectKey}&issuetypeIds=${issueType}&expand=projects.issuetypes.fields`)

Tried reinstalling the plugin, redeploying, but nothing helps.
My permission scopes:

    - 'write:confluence-content'
    - 'write:confluence-props'
    - 'read:confluence-content.summary'
    - 'read:confluence-props'
    - 'write:jira-work'
    - 'read:jira-work'

Hi @JoachimBollen, we noticed problems with authentication in Forge. I requested the relevant team to resolve this issue. Thank you for reporting it.

Hey @JoachimBollen,

I have attempted to reproduce this although this API is working for me from a Confluence app. How are you calling getCustomFieldValue? You need to make sure you are awaiting the response correctly otherwise your Forge function may cease execution before the Promise is able to resolve (this would be a race condition and may explain why it was observed to work previously). One way to do this in ui kit would be to use the useEffect hook as it supports asynchronous functions.

If this is not the case, feel free to message me with some more specifics about your use case if you feel uncomfortable sharing more here.

Thanks again for the report, hope this helps.

Hi @SamSmyth ,

Thanks for your reply. I’ve tested some more, and it seems there was something wrong in my code causing this issue. With some refactoring I got it to work.