Assets menu and features not available in AUI SDK environment

We have a JSM commercial data center license and with it the menus and features of the Assets Plugins are available. We would like to do some UI customizations around these Assets. In order to do so we installed the AUI atlassian SDK. However, in this development environment we’re not able to get the “Assets” working and showing up as a menu item, despite the fact that under “Administration > System > System info” of this development Jira server, the “Assets Plugin” shows up as enabled. We also tried to replace the “Evaluation JSM license key” which automatically comes with the SDK environment with a development license key we generated from our atlassian account. However, when trying to do so, we get a message that “Jira Service Management Data Center license doesn’t match your Jira Software Server license”. Can anybody advise on how we can get the “Assets Plugin” work in our AUI development environment?

I have to apply both my development Jira Software License AND the development Jira Service Management license to get the Assets feature showing in the SDK environment.

1 Like

Thanks @sfbehnke, that helps! I believe, we do not have a Jira Software License at this point, but will check with our Admins. As far as I know, the “Assests” are included in JSM.

Do you happen to know, if the “Jira Software License” automatically comes with the “Jira Service Management” license, or, do we have to purchase that extra, if we want to do some UI customizations within the Assets?

No, you don’t need to buy Jira Software. Within your SDK, you can simply uninstall Jira Software and that should resolve your issues with applying the JSM Development license.

By default, the SDK assumes Jira Software. This is a problem for you. It’s possible to launch the SDK using ONLY Jira Service Management, but I’d have to dig into that.

For now, I’d launch the instance, uninstall the Jira Software application from the Applications screen, then apply your JSM Dev License.

1 Like

Thanks again! Yes, the default seems like the SDK assumes Jira Software. I actually have tried to uninstall Jira Software from the Applications screen after launching the instance. However, I always get the error: “Unable to remove license, Jira needs to contain at least one license to be functional” (the error actually comes trying to remove “JSM” too, looks like by default they have the same license key, Jira Core as well)

I guess we’ll have to somehow figure out, how to launch the SDK using ONLY JSM without Jira Software. I will dig into that, but if you have hints regarding that, I’d appreciate it.

For those who run into the same problem…

We figured out how to get a Jira SDK instance with our development JSM license key up and running without the need of a Jira Software license key:
After the creation of the project, we enabled JSM in the pom.xml


(and set the corresponding versions in the <properties> section of the xml)

After starting the instance with atlas-run, uninstalling the Jira Software application from the Applications screen or only updating your JSM license key is not possible. However, you can open the DBConsole (via GUI menu entry) and enter your JSM Development license_key like this:
UPDATE PRODUCTLICENSE SET LICENSE='your_JSM_development_license_key_goes_here' WHERE ID=10000

A restart of the instance then shows the “Assets menus and features” and the GUI only shows the JSM License.

1 Like