Atlas-create-jira-plugin freezes after showing the "stable data version" in use

Hello everybody,

I’m facing a strange anomaly when trying to create a new plugin via atlas-create-jira-plugin: the latter freezes indefinitely (I’ve waited up to 10 hours or so) right after outputting the “stable data version” in use:

Executing: /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4/bin/mvn com.atlassian.maven.plugins:jira-maven-plugin:8.1.2:create -gs /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4/conf/settings.xml
Colorizing console...
[INFO] Scanning for projects...
[INFO] ------------------< org.apache.maven:standalone-pom >-------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] --------------------------------[ pom ]---------------------------------
[INFO] --- jira-maven-plugin:8.1.2:create (default-cli) @ standalone-pom ---
[INFO] using stable product version: 7.13.0
[INFO] using stable data version: 7.13.0

I’m using Atlassian Plugin SDK version 8.2.8 on Ubuntu 18.04.6 LTS.

I installed the Atlassian Plugin SDK (version 8.2.8) months ago, and at first it worked properly: I was able to create a couple of sample plugins. Then I stopped using it, and in the meantime I’ve updated my Java version (from 1.8 to 1.11, but got back to 1.8 when the SDK started complaining about Java), installed some Ubuntu updates and some new software (can’t recall exactly what and when), and something apparently caused the atlas-create-jira-plugin to stop working.

Same problem happens if I try atlas-create-confluence-plugin.

If I try to execute (atlas-run) one of my previous test plugins, though, the Jira server starts regularly on port 2990.

I’ve tried disabling Google Analytics, but that doesn’t seem to be the problem. I’ve also tried executing the atlas-create-jira-plugin with the -e and -X Maven options to get some more log messages, but I get none: the script simply freezes at that same point with no apparent error.

I’ve also removed and then reinstalled the Atlassian Plugin SDK, just in case, but it didn’t help.

I’m not behind a proxy, and my Internet connection doesn’t seem to have any problems.

This is the output of atlas-version on my PC:

ATLAS Version:    8.2.8
ATLAS Home:       /usr/share/atlassian-plugin-sdk-8.2.8
ATLAS Scripts:    /usr/share/atlassian-plugin-sdk-8.2.8/bin
ATLAS Maven Home: /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4
AMPS Version:     8.1.2
Executing: /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4/bin/mvn --version -gs /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4/conf/settings.xml
Colorizing console...
Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-17T20:33:14+02:00)
Maven home: /usr/share/atlassian-plugin-sdk-8.2.8/apache-maven-3.5.4
Java version: 1.8.0_301, vendor: Oracle Corporation, runtime: /usr/lib/jvm/jdk1.8.0_301/jre
Default locale: it_IT, platform encoding: UTF-8
OS name: "linux", version: "5.4.0-992202022022-generic", arch: "amd64", family: "unix"

Could anyone please help me understand what the problem is and how to solve it?
I’m probably missing something, but I can’t grasp what.