Atlas-mvn cannot find com.atlassian.plugins.rest:atlassian-rest-doclet:jar:2.9.2

Hello
I’m working on a restful endpoint for my plugin with the following element defined in atlassian-plugin.xml:

    <!-- add rest api endpoints -->
    <rest key="merge-manager" path="/merge-manager" version="0.0.1a">
        <description>RESTful endpoints for merge-manager.</description>
        <package>com.visier.bitbucket.merge.manager.controller</package>
    </rest>

However, when I ran atlas-mvn install -U , I got the following issue:

Downloading from central: https://repo.maven.apache.org/maven2/com/atlassian/plugins/rest/atlassian-rest-doclet/2.9.2/atlassian-rest-doclet-2.9.2.pom
[WARNING] The POM for com.atlassian.plugins.rest:atlassian-rest-doclet:jar:2.9.2 is missing, no dependency information available
Downloading from central: https://repo.maven.apache.org/maven2/com/atlassian/plugins/rest/atlassian-rest-doclet/2.9.2/atlassian-rest-doclet-2.9.2.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 7.761 s
[INFO] Finished at: 2019-06-24T16:20:38-07:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.atlassian.maven.plugins:bitbucket-maven-plugin:8.0.0:generate-rest-docs (default-generate-rest-docs) on project merge-manager: An error has occurred in Javadoc report generation: Unable to resolve artifact:groupId = 'com.atlassian.plugins.rest'
[ERROR] artifactId = 'atlassian-rest-doclet'
[ERROR] version = '2.9.2': Could not find artifact com.atlassian.plugins.rest:atlassian-rest-doclet:jar:2.9.2 in central (https://repo.maven.apache.org/maven2)
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

I have no idea where the com.atlassian.plugins.rest:atlassian-rest-doclet:jar:2.9.2 comes from, as I definately haven’t list it in the dependencies element of my pom.xml.

Then I realized that even the atlassian package system have abandoned version 2.9.2 of atlassian-rest-doclet.

Is it possible to replace it with a higher version or what else can I do?

Hi there! I’m commenting because I have encountered the same issue and desperately need help as soon as possible (time-sensitive project) and would like to follow any answers or guidance provided here.

I believe I’m in the same exact situation if I understand all your circumstances correctly, with the atlassian-rest-doclet package not being anywhere in my pom.xml file. And I additionally observed that upon maven failing to find the package locally, it tried looking for it online in its maven library, however the package has not been included in maven’s online repository, so it comes up empty. I have no clue how to work around this as of yet and can’t find anything online about the issue, which seems to pertain to some sort of larger issue in Jira with their REST module, so any help would be greatly appreciated!

Hello, I have a temporary solution: add the following section in your properties section of your pom.xml:

<maven.javadoc.skip>true</maven.javadoc.skip>
2 Likes