Atlas-run does not install my plugin automatically. UPM is empty

I am following the tutorial at https://developer.atlassian.com/server/framework/atlassian-sdk/create-a-helloworld-plugin-project/
After starting jira with atlas-run>atlas-run.log, the UPM is empty. It seems that the plugin is not installed automatically. Screenshot attached. I am unable to attach the log here.

The packaged jar in [myPlugin]/target/ has been tested with another instance and the plugin works fine. I am just unable to see it in my development environment.

Any help would be appreciated.
Thanks

atlas-run does install plugin automatically, change the user-installed to all and then search for your plugin name.

Can you check the base url of your instance? My guess is that it’s set to your machine’s dns entry - upm can have problems with accessing it from a different base url (http://localhost:2990/jira in this case).

Otherwise - I would look into the logs for the area where the plugins are initialized and see if there are any errors.

I encountered same problem.
In my case, my jar had an undefined property (Bamboo build number) for CI purpose.

<version>1.0.0.${bambooBuildNumber}</version>

I added the system property to atlas-debug and it works fine now.

atlas-debug -Dencoding=UTF-8 -DbambooBuildNumber=`date +%Y%m%d%H%M`-SNAPSHOT

Apparently, the issue was caused by using an older atlassian sdk .The plugin was created with SDk v6.3.7 . atlas-run was executed from the older sdk (6.2.14). I removed the older installation form $PATH and it works now. The plugin is automatically installed when I execute atlas-run.

The contents of pom.xml:

    <jira.version>7.6.1</jira.version>
    <amps.version>6.3.14</amps.version>
    <plugin.testrunner.version>1.2.3</plugin.testrunner.version>
    <atlassian.spring.scanner.version>1.2.13</atlassian.spring.scanner.version>

and Atlassian Plugin SDK - Windows | Atlassian Marketplace helped me uncover the issue.

Thank you everyone for all the help.

Hi! I am encountering a similar issue. When I run atlas-debug from the directory where in my POM Is defined, the plugin is not loaded automatically. How did you find that the plugin was created using a different SDK while atlas-run/debug was using a different SDK.
IIUC, the version used by atlas-run would be found with atlas-version and the version used to build plugin would be present in the POM?