Atlas-run fails with Dependency Resolution Exception

Hi!

I’ve been trying to get into plugin development for our JIRA and Confluence instances and wanted to start with the Hello World Plugin Demo Project (https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project/create-a-helloworld-plugin-project).

I ran into some issues along the way and I hope that you can help me resolve this. Once I get to “atlas-run” everything starts out fine and a lot of stuff gets downloaded, as expected. But ultimately the build fails with the following error:

[ERROR] Failed to execute goal on project myPlugin: Could not resolve dependencies for project com.atlassian.tutorial:myPlugin:atlassian-plugin:1.0.0-SNAPSHOT: Failed to collect dependencies at com.atlassian.jira:jira-api:jar:7.2.2 -> com.atlassian.applinks:applinks-api:jar:5.2.3: Failed to read artifact descriptor for com.atlassian.applinks:applinks-api:jar:5.2.3: Could not find artifact com.atlassian.applinks:applinks-parent:pom:5.2.3 in NexusServer (http://ournexus/nexus/content/groups/public/) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.

I am working with a Nexus behind a proxy and I am accessing a group repository that includes maven central, the atlassian repo and a bunch of others and the Nexus connects through a proxy. This should be working as intended, as he starts to download a lot through our nexus once I use “atlas-run”.

Looking into my locally cached libraries I have noticed that he appears to download everything but the actual jar-File of (e.g.) applinks-api-5.2.3. Same for the jira-api.

Has anybody experienced this issue before? Does anyone have an idea as to why I run into this problem?
I don’t understand why this is happening, but I hope that somebody here can help.

Any help or tips resolving this would be very much appreciated!
Thank you very much in advance!

Cheers,
Felix

Hey Felix,

I’m not too familiar with Nexus repositories but it does seem likely that it’s a problem with the configuration within your nexus repository.

I’ve checked the file is available at both of these locations:

Looking at Stack Overflow, there is another user with a similar issue and error - https://stackoverflow.com/questions/17389085/nexus-could-not-find-artifact.

It might be worth having a read of that to see if there is anything you haven’t already tried (and let us know if anything works!)

Cheers,
Melissa

1 Like

Hi Melissa,

thank you very much for you help!
Unfortunately the stackoverflow article didn’t help me resolve the problem, but it might have narrowed it down a bit.
Just to make sure that I didn’t miss anything that was suggested there, let me summarize what I have done so far:

Trying mvn clean instal -U did not help and neither did deleting the local folders on my end.
Next I tried using the ?describe parameter to see what Nexus does when I try to access this: http://companynexus/nexus/content/groups/public/com/atlassian/applinks/applinks-api/5.2.3/applinks-api-5.2.3.jar?describe

Once it reaches the atlassian repository in our group repository it apparently finds the artifact and the listed response code is 200 which should mean that I can actually access the applinks-api through Nexus, correct?
I have attached 2 pictures of the describe answer.


I can only add 1 picture at a time, so I will attach the 2nd seperately.

It appears that Nexus can access the artifact as expected, but doesn’t download the *.jar. The applinks-api-5.2.3.pom and applinks-api-5.2.3.pom.sha1 get downloaded onto my computer.

I still don’t understand why Nexus doesn’t download the jar, but at least it looks like it should be able to reach it.

Do you have an idea what I need to change to get it to work? I’m not sure what else I can try right now.

Cheers,
Felix

And here is the 2nd picture!

Hey Felix,

I’m not very familiar with Nexus to be honest.
I did some searching online and found another article for a user experiencing a similar issue - https://stackoverflow.com/questions/18470553/nexus-only-downloading-poms-from-central-repository-rather-than-jars

It seems to indicate that you might need to increase the timeouts in the connections settings in nexus.

This post also seems to indicate a similar solution http://maven.40175.n5.nabble.com/Nexus-retrieves-only-poms-and-no-jars-td131243.html.

Cheers,
Melissa