Atlas-run in tutorial causes 404 error

I followed the tutorial on

https://developer.atlassian.com/server/framework/atlassian-sdk/create-a-confluence-hello-world-macro/

But when I try to do atlas-run and open localhost:1990/confluence, I get a 404-error.
Also when I try my username:1990/confluence as printed in the console.

I already checked my java and sdk version multiple times. Atlas 6.3.10 Apache Maven 3.2.1 Java jdk.1.8.0_191 Running on win10 home.

Another strange behaviour, all atlas commands won’t refer to the changed working directory. All files were created in …/Atlassian/atlassian-plugin-sdk-6.3.10 and in the first lines it says “can’t find path” but my console says that I’m currently in the directory I wanted.

Any suggestions what I can do?

Hi!
404-page not found
Did You tried http://127.0.0.1:1990/

For command line give more info pls. Which OS? For Windows set atlasSDK bin to PATH (PATH=%PATH%;C:\atlasSDK\bin).
It work for me:
cd /directory where you want create plugin/
atlas-create-<conf/jira>-plugin //must create subdir artifactID with pom.xml
cd /artif ID where pom.xml/
atlas-run // must download server and run him

I’m using Microsoft windows 10 home 64 bit, version 10.0.17134.285 build 17134 on a HP omen 15-ce0xx laptop.

cd command works fine, can chance working directory, also all other windows commands work in the current working directory
Only atlas-commands that come with the sdk don’t work in my current working directory.
E.g.:
cd C:…\myfile
Atlas-create-confluence-plugin
will create a folder in C:\Applications\Atlassian\atlassian-plugin-sdk-6.3.10 but not in C:…\myfile

Also atlas-run only works in C:\Applications…\myConfluencePlugin, which gives the right localhost:1990/confluence/ back, but causes 404 error.
Will try http://127.0.0.1:1990/ at home soon.

Tried CMD and PowerShell, both the same.

Also atlassian sdk\bin is set in path.

Looks like You not have permission or some antivirus soft blocking. Check permission for folder and try run CMD as admin.

I checked http://127.0.0.1:1990/confluence but also get a 404 error page.

Deactivated antivirus software, run cmd and powershell as admin but nothing changed. Still 404 error page :frowning:

Will try it on a freshly installed windows 10, maybe it will solve the problem :roll_eyes:

Reinstalling Windows solved the directory bug!
So I’m still struggling with the 404 error…

Half problem is gone - it’s good :slight_smile:
How memory in your OS?
Are you see output in cmd?

Give pls C:\Atlassian\CONF\myartif\target\container\tomcat8x\cargo-confluence-home\logs after got 404 error.

1 Like

Memory and console output was always similar to yours. It also said that Tomcat was started on port 1990.

But it’s working now (for kind of no reason).

I installed a new Windows 10 Home, the first plugin I created didn’t work. I got the same 404 error.
Fortenately the second plugin I created (just the same way) works fine!
No 404 error, I can log into confluence server. Don’t ask me why. I changed nothing.

So I’m not able to give error logs. Never change a running system. Thanks for your help!