Atlassian Connect Express for Node 12.x?

https://developer.atlassian.com/cloud/jira/platform/build-a-jira-app-using-a-framework/

The framework seems to expect to work with Node 10.
The one at my OS (12.x) is yelling about plenty of deprecated dependencies when installing it.

Are there update of ACE in the pipeline with less deprecated stuff in the pipeline?

bitnami@debian:~/jira$ sudo npm i -g atlas-connect
npm WARN deprecated request@2.74.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated json-parser@1.1.5: json-parser is deprecated. Please use comment-json instead
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated har-validator@2.0.6: this library is no longer supported
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
/opt/bitnami/nodejs/bin/atlas-connect -> /opt/bitnami/nodejs/lib/node_modules/atlas-connect/bin/atlas-connect
/opt/bitnami/nodejs/bin/atlas-connect-new -> /opt/bitnami/nodejs/lib/node_modules/atlas-connect/bin/atlas-connect-new
npm WARN notsup Unsupported engine for got@5.7.1: wanted: {“node”:">=0.10.0 <7"} (current: {“node”:“12.16.1”,“npm”:“6.14.8”})
npm WARN notsup Not compatible with your version of node/npm: got@5.7.1

  • atlas-connect@0.7.0
    added 344 packages from 206 contributors in 99.411s

bitnami@debian:~/jira$ atlas-connect -V
0.7.0
bitnami@debian:~/jira$

Hi @matjung,

Are there update of ACE in the pipeline with less deprecated stuff in the pipeline?

We do make updates to this framework on a “best effort” basis. I’ll ensure the maintainers are aware of the deprecation warnings.

Regards,
Dugald

Hi @matjung ,

The output you’re seeing there is coming from installing the tool that bootstraps your connect app (atlas-connect), not from the framework itself atlassian-connect-express. @JohnJiang recently did a bunch of great work bumping the dependencies of the actual starter app so it’s in a much better state, but I now realise no-one has done the same thing in a long time for this project creation tool, and it’s not a good first impression.

Thanks for letting us know. Hopefully someone can freshen up atlas-connect soon as well.

Cheers,
James