Atlassian spring starter sample application url not found exception

Hi everyone,

I’m a new to the jira app development and I tried to create a basic application using the official support spring framework. I used the following sample application from the official bitbucket page: https://bitbucket.org/atlassian/atlassian-connect-spring-boot-samples/src/master/atlassian-connect-spring-boot-sample-ajax/

After I added the application in jira and try to load it I get a message: “something went wrong try refreshing this page”. I’m using ngrok for uploading my application and there I can see I get a 404 exception when trying to acces iframe.html. However when I try to access the same link without my jira client I don’t get this exception. A few weeks back I set the same application and then everything worked fine so I’m not sure what is causing this issue.

I did not make any major changes to the code inside this link so I hope this information is sufficient to help me.

Hi @Meelzak,

What did you provide as addon.base-url to your application? Common trap that I also stepped into a lot is leaving a slash at the end of the ngrok domain. So for example https://1234.ngrok.io/ instead of https://1234.ngrok.io. This has caused similar errors for me in the past. So, make sure there’s no trailing slash. Same with trailing spaces.

Easiest way to check this while the Server is running to simply have a look at the baseUrl field in the atlassian-connect.json.

Cheers,
Sven

Thanks @sven.schatter for the fast reply!
Unfortunately this is not what’s causing my issue, so I will look into it a bit further myself. If anybody has a solution or encountered the same problem feel free to leave a message because I’m a bit stuck right now.

Actually, looking at the code, I think I know what the issue is. The sample is still using:

<script th:src="@{${atlassianConnectAllJsUrl}}" type="text/javascript"></script>

This is deprecated and instead you need to load the all.js script from the CDN now like this:

<script src="https://connect-cdn.atl-paas.net/all.js" type="text/javascript"></script>

Pretty sure this should solve your problem. Also summoning @epehrson to let him know that the samples might deserve a small update in this regard. :slight_smile:

Cheers,
Sven

@sven.schatter good catch :slight_smile:

I have upgraded that sample to the latest atlassian-connect-spring-boot, and with that it seems to work fine. I’m afraid we don’t have bandwidth to keep those samples up-to-date, so I’ve added a disclaimer to the repository README.

1 Like