AUI 9.1 is released!

We have just released the 9.1.0 version of AUI.

The key (and only) change between version 9.0.3 and 9.1.0 is the update of AUI’s internal dependency - Popper.js.

This also solves the issue with AUI’s Dropdowns being wrongly positioned under certain conditions in Edge 18

That’s the awesome contribution of @mdyro - kudos for the execution mate! :slight_smile:

On top of that we have a new home for our docs :wink: It took some time to migrate but you can visit them here: https://aui.atlassian.com/aui/9.1/

@BobBergman - I remember your last comment about some dead links - they should be fixed now :slight_smile: Thanks again for finding those for us :slight_smile:

:heart:,
The Server Platform

6 Likes

Congrats!
I am finding lot’s of unreachable links under the docs especially older versions(8.0, 7.10, 7.9, 6.1, 5.10) could you maybe look into it?

Best regards

Thanks, will find and fix them :male_detective:

Can you give me some examples to make my life easier? :wink:

Sure here you go:

I am guessing it won’t be your area/responsibility but these links are broken as well: https://studio.atlassian.com/wiki/display/ATR/Home
https://atlassian.design/server/

Thank you!

I’ve just fixed the links for AUI - the others are outside my jurisdiction :slight_smile:

To see the changes you have to clear the browser cache.

1 Like

Thank you @BartoszCytrowski as well!

Unfortunately the 8.0 link still seems down. I have tried it over FF, FF-Dev, EDGE, Chrome, DDG(Android) each after deleting the cache and also in private window to make sure. On 2 different networks as well.
I don’t/didn’t mean to create you more work but I thought I still should share this.

Best Regards

It works for me - I checked on FF and Chrome. Try opening the dev tools. Then right-click the refresh page icon and use “Empty Cache and Hard Reload” option.

I did exactly as you said. Still the same behaviour. I even went as far as to try with different devices, browser, networks even. WLAN at the office, LAN at home. LTE from Mobile carrier. Friends at different cities, all ended up on 404 unfortunately. We are all in Germany.
FF:

Edge(Chromium)

Could I kindly ask you to maybe provide the Documentation in some other form?

I will see what I can do here and get back to you soon.

1 Like

Have you tried visiting the page in the incognito mode? Do you get the same HTML when you run: curl https://aui-docs.us-east-1.prod.public.atl-paas.net/aui/8.0/docs/inline-dialog.html?

Yes I have tried incognito mode as well in the previously mentioned tries. I pasted the curl command in my WSL Ubuntu Bash shell it seems to be the proper HTML with the expected content

Can you access https://aui-docs.us-east-1.prod.public.atl-paas.net/aui/8.0/docs/inline-dialog.html in the browser? This one shouldn’t be cached.

Yes I can reach it without a problem. Although some things seems a bit weird but might be expected for you as well.
When I open your link it opens the 8.0 inline-dialog but on the top navigation bar it says version 8.0.6. When I then select 8.07 from the drop down menu, it gives me a 404 again. With that link, not even version 9 gets delivered, ending up with 404 as well.

Ok, so it was definitely some cache problem. Maybe you are behind some proxy that caches server responses for you. To verify that you can try curl the address you checked before - the one that gave you 404 in the browser. If the page content is 404 error page then there is some stubborn cache between you and our server.

1 Like

Maybe the oversea servers/my ISP here needs a bit of time to realise the change and I am acting too fast. Thank you for your effort.

1 Like

They all work like a charm now. Again thank you for your effort!

2 Likes

Good news, if my memory serves me well AUI 9.1 was supposed to bring dark mode capability to Jira Cloud - or am I mistaken?

Just FYI, I am getting 404’s for the changelog link on newer versions:
https://bitbucket.org/atlassian/aui/src/9.1/CHANGELOG.md

1 Like

That’s one more thing we have to fix after migration. Here is the actual URL: https://bitbucket.org/atlassian/aui/src/9.1.0/CHANGELOG.md

The problem is related to the change in URL scheme we use. Previously it was {major}.{minor}.{patch}. Right now we skipped the {patch} part in the URLs on the docs page and we override the {major}.{minor} HTML. I missed the fact that on bitbucket we still use the full version in URLs since it’s the actual tag name.

Hi Greg!

Thanks for your comment.
To be honest, though - I am a little bit confused with your message.
Let me explain, why.

Indeed - with AUI 9 we broughtin themeability ( you can read more about that in this thread: The direction for AUI 9 ) with dark-mode being one of the default themes shipped with AUI.

Unfortunately - this is not just a simple drop-in replacement for products to fully utilise the new capabilities; not even to mention a full, cross-all-views dark-mode support. There’s way more work that our dev teams need to process before we can release proper theme support in products.

What is important, though, is that virtually all product teams have ongoing initiatives around the dark-mode theme.

In case of Jira Server - you can follow (and vote!) the thread in this ticket: https://jira.atlassian.com/browse/JRASERVER-63150

It’s even trickier when it comes to Jira Cloud.
As majority of Jira Cloud is React-based, it uses a react-oriented alternative to AUI - Atlaskit. You can find more details on the library on https://atlaskit.atlassian.com/

Atlaskit already comes with (experimental) theme package ( https://atlaskit.atlassian.com/packages/core/theme ) and as far as I am aware - there’s some significant progress in bringing full-scale themeability to the library.

As a consequence - Jira Cloud has already made enormous progress towards the dark-mode goal. Does it mean it’s close to be “done-done”?
Definitely not.
As you can imagine - the amount of work required to fully implement it is pretty significant. You can read on that (and vote!) in this ticket: https://jira.atlassian.com/browse/JRACLOUD-63150

I’m sorry to hear that AUI’s announcement might have confused you. I understand that it’s all a complicated mix of interconnected jars and it is extremely easy to get lost in the messaging.

I hope this message will help you better understand the state of all our dark-mode efforts.

Best regards,
:fox_face: Fox
TEC team.

1 Like