Bitbucket pipeline keeps asking for Forge analytics even though disabled

When running the pipeline:


But in command line I have set:
forge settings set usage-analytics false
Which returned:
:heavy_check_mark: Successfully set usage-analytics as false.

Unclear why it still asks even though I have set it to false

Hey @ShawnSun,

This setting is specific to your local CLI installation, so you will need to run forge settings set usage-analytics false in your pipeline after installing the CLI. If you are already doing that can you please share more details of your pipeline so I can assist you further.

Hi @SamSmyth ,
I started seeing a similar error recently in my pipeline deploy script. I get an error that my forge login --non-interactive requires an analytics setting despite the fact that the previous line of the script did just that. Here’s a capture of the script output and error

Build setup
26s
echo "Deploying $APP_NAME to $SITE ($ENVIRONMENT) under user $LOGIN_USER"
<1s
npm -g config set user $USER
<1s
npm root -g
<1s
npm install -g @forge/cli
10s
forge --version
1s
+ forge --version
2.0.4
forge settings set usage-analytics false
1s
+ forge settings set usage-analytics false
✔ Successfully set usage-analytics as false.
forge login --email $LOGIN_USER --token $LOGIN_TOKEN --non-interactive
1s
+ forge login --email $LOGIN_USER  --token $LOGIN_TOKEN --non-interactive
Error: --non-interactive requires an analytics setting. Use forge settings set usage-analytics <value>.
Rerunning the command with --verbose may give more details.

Hey @jeffryan,

This is implementation specific so subject to change in future versions of the CLI but sharing to possibly help you debug. We currently use the conf package to store this data, it appears it uses these system specific paths. Hopefully gives you something to dig into, if it’s no help we will probably need more context to reproduce your specific case.