"Can not deserialize instance..." error when trying to run POST JSM command in Zapier

Has anyone used Zapier webhooks actions for JSM Cloud API POST calls? I’m trying to run a POST create organization call through a Zapier action step, as part of a new customer support setup flow I’m working on, that creates an organization in Jira Cloud and adds it to our Support JSM project. However, I get the error in the screenshot attached. I believe I have all the data and Headers setup right (also can be seen in the attached). I tried both “Basic” and “Bearer” in the “Authorization” header, but get the same error.

I’m a relative novice to APIs, but have managed to work w/ others (like Slack) and get them running fine in the same Zapier zap as this POST will be included in. I just can’t figure this Jira api one out.


Welcome to the Atlassian developer community @CoreyLaverdiere,

I don’t know much about debugging Zapier. I typically work directly with an API client. When I tried to reproduce the problem, I noticed this request is very limited. Like you said, headers are probably fine. Zapier would break for every request otherwise. But the body needs to look like this:

  "name": "Charlie Cakes Franchises"

And you have an option that reads “Wrap Request in Array” set to true. When I try to do that in my client, I get the same error. Maybe that should be false.

Thanks. I managed to get it to work in Zapier by using their custom request webhooks type (not form or json as I had been trying). It allows you to pass raw json for the data body, which worked.

1 Like