Cannot enable sharing for the forge app

Cannot enable sharing for the forge app. For some reason edit button is disabled.
I do not see any help/suggestion texts at the developer console.

1 Like

Hi, just want to confirm if your app is on marketplace, if yes there is an existing limitation that distribution is not supported post its availability on marketplace.

You can confirm if the above is true. If it is correct, it would be great to understand your use case on why you would like to distribute the app after it is available on Marketplace.

It is not listed yet. Actually, I’m in the process, marketplace pointed me to the developer console to enable sharing

1 Like

Right, one more question from my end, have you deployed your app on production environment ?

If this also didn’t work, would you mind sharing your app-id and the entire distribution page screenshot with me in DM ?

yes, 3 times

Sorry, how I can DM you here?

If you click my profile, you should be able to see an option to directly message.

I just sign-up here, I think the feature not enabled for newbies. Could you ping me at DM

Thanks for the details via mail. I will get back on this soon.

Hi @Alexandr ,

We have investigated the issue and found that you have enabled licensing in your app . Licensing is for paid apps and if enabled it won’t be shared via installation links .

You can read more about it here If this is not intended , you can remove the license config from your manifest file and redeploy the app. Let us know if this works !

1 Like

But my app will be paid, and I want to list it on the marketplace. If I turn off the license - it will be a free app?

If its a paid app , then it cannot be distributed via the installation links. The app needs to be installed via marketplace.

Sorry, but why did you decide that I distributed it via the installation links?
Here is my steps:

  1. enable license (because my app is not free)
  2. go to my marketplace vendor account
  3. click to create a new app
  4. select my forge app - and here is the problem, it ask me to go to developer console and enable sharing. You said that I should remove licensing to enable sharing, but in this case my app will be free, it is vicious circle :slight_smile:
1 Like

Got it. So you can follow the below steps ,

  1. remove the license config from your forge app and deploy the app
  2. In the developer console now enable sharing for your app and test your changes.
  3. Now follow the steps mentioned here - and submit your app for listing.
  4. Once the app is submitted for listing you can enable the licensing for the app and deploy it to production -
1 Like

Got it, thanks for the clarifying

1 Like