Cannot install atlaskit component @atlaskit/dropdown-menu

Hello, community,

Today I am facing an issue with installing the ‘dropdown-menu’ atlaskit react component in our app. Below is the error getting:

npm install @atlaskit/dropdown-menu
npm ERR! code ETARGET
npm ERR! notarget No matching version found for @atlaskit/portal@^3.1.4
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget
npm ERR! notarget It was specified as a dependency of '@atlaskit/tooltip'
npm ERR! notarget

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/xxxxxxx/.npm/_logs/2020-01-08T09_26_01_852Z-debug.log

I tried clearing the npm cache but didn’t work.
I would appreciate your help on this. Thanks in Advance.

Which version of dropdown-menu are you using? Atlaskit isn’t that great at pushing out nested dependencies at the same time so you might need to drop down a version or so.

/Daniel

Thanks, @danielwester for your swift response.

Earlier I tried with @atlaskit/dropdown-menu@8.2.0 version. And also I tried with 8.1.4 to 8.0.0 but didn’t work.
However, I could install a 7.0.0 version.

Looks like there’s something weird going on with the @atlaskit/tooltip component. The source seems to have stopped updating at the 14.x versions. Yet there are 15.x versions published to npmjs. The documentation page has references to an atlassian-frontend repository though…

@nmansilla - is it possible to ping the Atlaskit team to take a look?