Cannot load image from even though csp policy is set

Hello everyone,

I have been trying to get the Issue priority icons (e.g https://[MY-DOMAIN]
For this i added the following to my manifest yml:

    - write:jira-work
    - read:jira-work
    - storage:app
      - 'unsafe-inline'
      - ''
      - '*'

But when running the app i still get the following error:
Refused to load the image ‘icon/16px/medium-priority’ because it violates the following Content Security Policy directive: “img-src ‘self’ data: blob:”.

The images source which i have added in the manifest (‘*’) does not work. According to this resource it should work like this

How can I fix this issue ?

Thanks in advance

Best regards,

1 Like

Did you manage to get the ‘*’ working? I get a CSP error

I am experiencing the same issue. I would appreciate any findings on this.

I had the same problem and I’ve noticed that the images within atlassian domain are redirected, see the screenshot:

I’ve configured my manifest.yml for both domains and it solved the problem:


Another thing I found is that the wildcards weren’t working, but entering a domain with protocol worked just fine.

Try with just domain (like in the snippet above), no quotes, no slash at the end. Hope that helps!

1 Like

Unfortunately, service desk issue type icons do not seem to have a redirect to