Can't call Jira API from forge confluence module

I am trying to build a custom reporting tool in Atlassian forge. The app is set up as a confluence module. The problem is any call to the Jira API returns an error message of “The app is not installed on this instance”. What does this error mean and how can it be fixed?
image

Here is the snippet of code I am trying to run.

Hi @ColbyWilson1 ,

In order for the app to be authorised to call an API in Jira, the app must also be installed in Jira (even if the app has no Jira-specific functionality). The installation process also handles the API authorisation that is needed to call the Jira API from the Confluence installation of your app.

However, I am concerned that a recent change internally in Forge may have broken this… so if you try to do the second install, it still may not work. I am following up internally about this and will let you know if I have any further updates.

Can you share some more detail about the app you’re building? Is it just for use within your company, or are you hoping to distribute this app to others?

Thanks for using Forge :slight_smile:
Joe

2 Likes

Thanks, installing it onto Jira worked. The app was just for internal use.

It worked for me also, a question, how is that handled license-wise, if you only want to license the Confluence macro and not the jira part?