Can't make calls with 3LO

Im trying to use the JIRA API.

According to the documentation, I must retrieve the authentication code once the user has logged, then exchange it for the access token. Finally, I must get the cloudId of my site.
So far, doing all of this I got a get call that retrieves:


So seems like everything is okay, however when I try to build a URL to make a get call it always return a 404. Documentation says that urls should look like this: and I already tried with some similar to that one and don’t work (Obviously with my cloudid and the access token).

Can someone tell me how can I make APIs calls for both Confluence and Jira using 3LO?

Welcome to the Atlassian developer community @AllnTrejosSalazar,

I was able to successfully use my access token to call the project resource so it’s not systematically broken. I also tried a few variations that may help us diagnose your problem.

When I change my Bearer token to foo (an invalid token), then I still get a 200 but with an empty JSON array.

When I change my cloudid to foo (an invalid Cloud ID), then I get 404 with an error body:

	"timestamp": "2023-09-27T17:22:55.767972Z",
	"status": 404,
	"error": "Not Found",
	"message": "No message available",
	"path": "/ex/jira/foo/rest/api/2/project"

I’m not sure what’s going wrong between the accessible-resources and your URL construction, but it seems like there’s a wrong cloudid in there somehow. Maybe you can confirm by seeing if my URL gives you a different response:

There is another way to check your cloudid. Use GET on the /_edge/tenant_info path. For example, you can see my cloudid using (cloudids are no more secret than the URLs):

So far, it looks like you are on the right path. As long as your OAuth app has both Jira and Confluence scopes, it can get authorization to the site and access endpoints for both.

Let us know what you learn.

Hello, thanks for your answer.

Well, I made some changes and the call to rest/api/2/project gets:
So, seems like it is working, however I’d like to maybe get all the issues in a project called TEST and doing this calls:

mainUrl =



(To get an specific issue in jira)



I get 403:Forbidden, so this is so weird. Acording to the documentation, 403 is returned if the user does not have permission to complete this request however scopes and access token are okay :thinking:

By the way, I’m currently using java and this is my code so far:

private void getIssues(){
//I have change apiUrl to the options I mentioned above
        String apiUrl = "mainUrl/MY-CLOUD-ID/rest/api/2/events";

        try {

            URL url = new URL(apiUrl);
            HttpURLConnection conn = (HttpURLConnection) url.openConnection();

            conn.setRequestProperty("Authorization", "Bearer " + accessToken);

            int responseCode = conn.getResponseCode();

            if (responseCode == HttpURLConnection.HTTP_OK){

                BufferedReader reader = new BufferedReader(new 
                StringBuilder response = new StringBuilder();
                String line;

                while ((line = reader.readLine()) != null){

            } else {
                System.out.println("ErrorCode: " + responseCode);
                System.out.println("ErrorMessage: " + conn.getResponseMessage());

        } catch (IOException e) {

Running this code I get:
ErrorCode: 403
ErrorMessage: Forbidden