Confluence Development(OpenShift) SAML Single Sign On failed


I’m currently working on a Confluence data center deployed with Helm charts and after setting up saml sso I’m no longer able to access the web-gui.
This instance of Confluence is running on OpenShift using pingfederate for SSO and every time I follow my route to login I get the error " SAML Single Sign On failed
Please contact your administrator and provide the tracker-id EHTVT or log in at the [login page]
Handling SAML-message failed: No IdP configuration found for ldp1"

I’ve tried multiple routes to bypass the sso to login and adjust the ldp configuration but i’m having no luck. I’ve followed the documentation troubleshooting located here: “Enable default login page to bypass SAML in Confluence Data Center | Confluence | Atlassian Documentation
None of these solutions actually bypass the sso as it just redirects back to the sso failed page. Every web bypass just redirects.

So far I’ve tried the following without success:

  • web bypass (multiple)
  • Turing off sso on the pingfederate side
  • Helm chart re-deploy
  • confluence.cfg-xml reset (setting this back to “setup” leads to server 500 error)

I’d appreciate any direction/suggestions I could get on this issue.

Deployment Info:
Helm repo
Confluence-2.0.6 App Version: 7.14.3
Pingfederate SAML SSO 2.0

pod log via atlassian-confluence.log:
“2023-08-03 11:38:39,790 WARN [atlasplugins.samlsso.servlet.ServletUtil] sendErrorHelper Tracker: AuthenticationTrackerActiveObjectsProxy trackerid: EHTVT
– referer: | : /plugins/servlet/samlsso | traceId: 1efbb6ce651bd479 | userName: anonymous”

If more information is needed please let me know!