Confluence REST API - Get Blueprint Templates (no results)

Ok, so I’ve been working on a Confluence App. Monday I was able to retrieve a list of the Blueprint templates. Wednesday, I could no longer pull them even though I haven’t changed that code. I tried in our production instance and it gets results. My newer test instances don’t.

Observation:
The newer instances don’t appear to have the default blueprint templates that our production instance contains. See attachments.

On Monday I was pulling back the small set in the newer instance, but again, starting Wednesday that all stopped. I’d like to submit my new app for approval but not sure I should with this issue (which is out of my control).

Has anyone else experienced this? If yes, do you have a solution or is it one of those “it is what it is” situations?

Production Instance

Stage Instance (and all newer instances we’ve created)

Hi @LorenzoPhillips,

The screen shots you provided look like the Global Templates and Blueprints admin settings page: https://your-tenant.atlassian.net/wiki/pages/templates2/listglobaltemplates.action

I visiting this page in a recently created test tenant of mine and saw a lot more blueprints and templates so maybe the different behaviour relates to how you created your tenant. I created mine from the link http://go.atlassian.com/cloud-dev. Is that how you created your tenant?

Regards,
Dugald

Dugald,

Thanks for responding. So, these instances are fairly old or were created prior to the new UI rollout. Our dev environment was created using the cloud-dev link. Our production instance is the oldest and has been around for a few years. Now, the test/stage instances were not created with the cloud-dev link. But it was retrieving the smaller number on Monday, but by Wednesday it was not pulling them any longer. Also, they were created prior to the new UIs rolling out so I wonder if an update has been applied to them such that the other templates are no longer there since they are free instances.

I am going to check to see if there is a version difference. I know our prod instance is not a standard version and I know that the dev environment was created with the cloud-dev link you’ve listed in your response.

This is probably not a huge deal because if the templates are there, my code will pull them but it caught me off guard since I was getting results and now I am not. However, as an Atlassian partner I am aware of the many changes taking place. For example, the the new Trash Bin in Jira finally made it to all of our instances.

At any rate, I’ll dig around some more. Thanks again for your response!

1 Like

UPDATE: So, I checked the instances and the only difference I could find is that the ones that had the templates were on Standard version and the ones without the templates were on Free version. I updated a couple just to see if anything changes, but again this does not affect my app because if they are there they will show and if not, I display a “No data” message so nothing breaks.

Also, I remembered opening a post the other day about the templates would randomly change to another language when my app pulled them. I took my app out of the equation and went directly to Confluence and got the same random results when I took the templates into Edit mode. That seems to have stopped so I definitely think something behind the scenes is going on.

1 Like

FINAL UPDATE: Ok, it appears that the page templates show up as spaces are created to use them. Which explains why Dev and Prod have a bunch more since they have many more spaces. I created a KB space in one of the instances that only had one space and new templates showed up in the Confluence admin panel under Templates and Blueprints. Mystery solved. :slight_smile:

2 Likes