Connect hello-world repository missing?


I’m doing the connect hello world tutorial but can’t clone the base repository in this step. Running git clone produces this error:

remote: The requested repository either does not exist or you do not have access. If you believe this repository exists and you have access, make sure you're authenticated. fatal: unable to access '': The requested URL returned error: 403

Cloning other bitbucket repos works fine and I am logged in. Does anyone else get this behavior or have ideas how to get around it?

Thank you

Hey @UweKoch,

This repository should now be available. Please try again and let us know if your run into any difficulties.

1 Like

Thank you @SeanBourke, I was able to clone the repo. There are more issues though. After npm install I run npm start and got this error:

Failed to establish local tunnel
Make sure that ngrok is installed: npm install --save-dev ngrok

With that fixed I was able to enter the macro in the confluence page editor, but I then got this error:

I checked the ngrok version, it was 5.0.0-beta.2. I tried version 4, but that produced a Failed to establish local tunnel error. So now I’m stuck again. I’m on Windows 11, if that makes a difference.

If the tunneling doesn’t work, can I deploy manually somehow?

Hi, UweKoch

My personal laptop is also Windows 11, and it seems it is working for me. I have created totally new ngrok account (free subscription) for having a fresh eye as well as cloning the repo from the scratch. I tried wsl2 too, and confirmed it is working too

Can you please confirm if you went through

sign up your ngrok account and setup the authtoken as ngrok - Online in One Line instructed

once you come up to the stage where you successfully install the app to see this screen;

access this ngrok url from your browser, and click the Visit site

Then you will be able to see your descriptor json object successfully. From this point, your macro can successfully render your iframe. Without clicking Visit site, iframe fails to load the iframe html content for free account

If you can’t see the Visit site page, but still getting 6022 error with ngrok url, this is most likely your ngrok auth token issue that you may need to figure out. Perhaps you can try this → Ngrok issue ERR_NGROK_6022 - #5 by tdcardoso

Thank you @JamesByun, I didn’t know what ngrok is and that I need an account there. The guide doesn’t mention it at all. While I look into it, is there an alternative way to connect to app server to the confluence instance?

Sorry about missing documentation around ngrok; as it is a third party solution being evolved, we missed updating our documentation. We are on it! (I am under @SeanBourke’s team)

Unfortunately, Connect app installation service blocks the app server localhost access, which means app developer needs some tunnelling solution so that your descriptor file can be accessed through https protocol. You can use other option other than ngrok if you want to, such as Cloudflare tunnel, Localtunnel etc.

Once you find any tunnel solution to expose your app server access from public, you can override the AC_LOCAL_BASE_URL environment variable when developing. This sets the baseUrl and developers can then install the app via development mode.

For example,

  1. start tunnelling
  2. run AC_LOCAL_BASE_URL="" npm start in a separate terminal

OR if you do not want to auto-register (auto-install)

  1. delete credentials.json file
  2. start tunnelling
  3. run AC_LOCAL_BASE_URL="" npm start in a separate terminal
  4. go to UPM ( and upload your descriptor

Hope this helps!



Hi @JamesByun ,
thanks for the explanation of AC_LOCAL_BASE_URL. This allows us to NOT use ngrok with self registering, as ngrok is an issue in our environment.

1 Like

That did help! Thank you @JamesByun, I went with localtunnel and AC_LOCAL_BASE_URL.

1 Like