Creating custom theme 404 deprecated_addon_key error when I go to space overview

I’m trying to create a simple custom theme for Confluence cloud. It seems to work ok everywhere else, but I get an error when I navigate to /spaces/my-space-key/overview. The page never loads and this is the error I get:

GET /spaces/KD?tz=America%2FNew_York&loc=en-GB&user_id=admin&user_key=8a7f808362187f0c01621aadd5140010&xdm_e=https%3A%2F%2Ff8f.atlassian.net&xdm_c=channel-f8f-confluence-dark-theme__f8f-confluence-dark-theme&cp=%2Fwiki&xdm_deprecated_addon_key_do_not_use=f8f-confluence-dark-theme&lic=none&cv=1.3.517&jwt=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJzdWIiOiI4YTdmODA4MzYyMTg3ZjBjMDE2MjFhYWRkNTE0MDAxMCIsInFzaCI6Ijk3NGJhNDA0MGVmY2Q0ZGZiMTEyZWY2ZWFjNDdlOWFiMTc3NGM2ZmViYjM5ODQ4YjNiYWYyNjU4ODYyZDQxYjAiLCJpc3MiOiJhMGRlMjgxMC1kZWRlLTMxNDQtYjU5Yi05NGNmMzNiNjA2MGIiLCJjb250ZXh0Ijp7InVzZXIiOnsidXNlcktleSI6IjhhN2Y4MDgzNjIxODdmMGMwMTYyMWFhZGQ1MTQwMDEwIiwidXNlcm5hbWUiOiJhZG1pbiIsImRpc3BsYXlOYW1lIjoiS2FyYSBNYWNMYWNobGFuIn19LCJleHAiOjE1MjQxNjQ4MDcsImlhdCI6MTUyNDE2NDYyN30.Zg3sOi42eItqmpOBnSrL_8yAGXyp78CTaY8f4EO-WUk 404 6.475 ms - 148

And here is my generated add-on descriptor:

{“key”:“f8f-confluence-dark-theme”,“name”:“Confluence Dark”,“description”:“A Dark Theme for Confluence Cloud”,“vendor”:{“name”:“Forty8Fifty Labs”,“url”:“https://www.forty8fiftylabs.com/"},“baseUrl”:“https://karamaclachlan.ngrok.io”,“links”:{“self”:“https://karamaclachlan.ngrok.io/atlassian-connect.json”,“homepage”:“https://karamaclachlan.ngrok.io/atlassian-connect.json”},“authentication”:{“type”:“jwt”},“lifecycle”:{“installed”:"/installed"},“scopes”:[“read”],“modules”:{“confluenceThemes”:[{“key”:“f8f-confluence-dark-theme”,“routeOverride”:false,“availableGlobally”:true,“icon”:{“width”:512,“height”:512,“url”:"/img/icon.png"},“name”:{“value”:"Confluence Dark”},“description”:{“value”:“Confluence Dark: Black as your soul.”},“routes”:{“spaceview”:{“url”:"/spaces/{space.key}"}},“lookAndFeel”:{“header”:{“backgroundColor”:"#000000",“button”:{“backgroundColor”:"#7c7c7c",“color”:"#FFFFFF"},“primaryNavigation”:{“hoverOrFocus”:{“backgroundColor”:"#7c7c7c",“color”:"#FFFFFF"},“color”:"#FFFFFF"},“search”:{“backgroundColor”:"#FFFFFF",“color”:"#000000"},“secondaryNavigation”:{“hoverOrFocus”:{“backgroundColor”:"#7c7c7c",“color”:"#FFFFFF"},“color”:"#FFFFFF"}},“content”:{“screen”:{“gutterBottom”:“default”,“gutterLeft”:“default”,“gutterRight”:“default”,“gutterTop”:“default”,“backgroundColor”:"#919191"},“body”:{“borderRadius”:“5px”,“padding”:“5px”,“backgroundColor”:"#919191"},“header”:{“borderRadius”:“5px”,“padding”:“5px”,“backgroundColor”:"#919191"},“container”:{“borderRadius”:“5px”,“padding”:“5px”,“backgroundColor”:"#919191"}},“bordersAndDividers”:{“color”:"#2D30F2"},“headings”:{“color”:"#e01f21"},“links”:{“color”:"#2D30F2"},“menus”:{“color”:"#000000",“hoverOrFocus”:{“color”:"#FFFFFF",“backgroundColor”:"#7c7c7c"}}}}]}}

Any help would be appreciated! Thanks!

I get the same thing! I tried cursing, pleading, and crying, to no avail. Hope someone has the answer.

1 Like

You pasted the entire url that was called with querystring variables… I don’t see an error here. What error are you seeing?

It’s a 404 error. If I have my theme turned off in the space, it loads fine. But if my theme is enabled I get this 404 when I go to /spaces/key/overview. But I can get to /spaces/key/blog fine.

This is what I see in my ngrok terminal:
GET /spaces/KD 404 Not Found

Can you upload the generated descriptor file for us to look at. It’s hard to debug with the template variables in it still.

edited post for clarity. Sorry

I’m having the same issue creating a custom theme. I see both errors in the terminal when i try and load the overview page,

GET / / icon.png 404 2.081 ms - 148

and

GET /space/SITE?tz=Europe%2FLondon&loc=en-GB&user_id=admin&user_key=8a7f8085645ce79d01645dec01fc000f&xdm_e=https%3A%2F%2Fslys-dev.atlassian.net&xdm_c=channel-my-add-on__my-first-theme&cp=%2Fwiki&xdm_deprecated_addon_key_do_not_use=my-add-on&lic=none&cv=1.87.0&jwt=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJzdWIiOiI4YTdmODA4NTY0NWNlNzlkMDE2NDVkZWMwMWZjMDAwZiIsInFzaCI6IjBkMTk4MzViY2ViMjA4YWYyM2YyY2FjYTA0MDcwZTFkNDI0NzQwYzdmNjdhMjBiMDQ5ZWJlZDAwY2ZhZWFkMWUiLCJpc3MiOiJiZDg3MzkzOS1lYTQ3LTMzMTMtYTEyNC1mNjQ0ZGYyYWM2YTUiLCJjb250ZXh0Ijp7InVzZXIiOnsidXNlcktleSI6IjhhN2Y4MDg1NjQ1Y2U3OWQwMTY0NWRlYzAxZmMwMDBmIiwidXNlcm5hbWUiOiJhZG1pbiIsImRpc3BsYXlOYW1lIjoiU3lsdmVzdGVyIE1iYWd3dSJ9fSwiZXhwIjoxNTMwNzAzNjUyLCJpYXQiOjE1MzA3MDM0NzJ9.Ao4ZUKUm4DwCUq3EuGL6AqVfWFAtAmrRPtdWiSFLOyg 404 0.998 ms - 149

and here’s my descriptor

{
“key”: “my-add-on”
, “name”: “Ping Pong”
, “description”: “My very first add-on”
, “vendor”: {
“name”: “Angry Nerds”
, “url”: “https://www.atlassian.com/angrynerds
}
, “baseUrl”: “{{localBaseUrl}}”
, “links”: {
“self”: “{{localBaseUrl}}/atlassian-connect.json”
, “homepage”: “{{localBaseUrl}}/atlassian-connect.json”
}
, “authentication”: {
“type”: “jwt”
}
, “lifecycle”: {
“installed”: “/installed”
}
, “scopes”: [
“READ”
]
, “modules”: {
“generalPages”: [
{
“key”: “hello-world-page-jira”
, “location”: “system.top.navigation.bar”
, “name”: {
“value”: “Hello World”
}
, “url”: “/hello-world”
, “conditions”: [{
“condition”: “user_is_logged_in”
}]
}
, {
“key”: “hello-world-page-confluence”
, “location”: “system.header/left”
, “name”: {
“value”: “Hello World”
}
, “url”: “/hello-world”
, “conditions”: [{
“condition”: “user_is_logged_in”
}]
}
]
, “confluenceThemes”: [{
“key”: “my-first-theme”
, “routeOverride”: false
, “availableGlobally”: true
, “icon”: {
“width”: 110
, “height”: 70
, “url”: “/icon.png”
}
, “name”: {
“value”: “Hello World Theme”
}
, “description”: {
“value”: “My first Connect theme.”
}
, “routes”: {
“spaceview”: {
“url”: “/space/{space.key}”
}
}
}]
}
}

Might be related to: https://jira.atlassian.com/browse/CONFCLOUD-65593