CSS not loading in report

I am developing a jira server report and I am not able to load my css file.

In my atlassian-plugin.xml I define my web-resource like this:

    <web-resource key="jira-reports-resources" name="wl-jira-report-plugin Web Resources">
        <resource type="download" name="jira-report-plugin.css" location="/css/jira-report-plugin.css"/>
        <resource type="download" name="jira-report-plugin.js" location="/js/jira-report-plugin.js"/>
        <resource type="download" name="images/" location="/images"/>

and my report like this:

    <report name="Massnahmen Verantwortlichkeit Report" i18n-name-key="report.massnahme.name"
            key="massnahme-report" class="com.example.reports.massnahme.MassnahmeReport">
        <description key="report.massnahme.description"></description>
        <resource name="view" type="velocity" location="/templates/reports/massnahme/view.vm"/>
        <resource name="i18n" type="i18n" location="report-massnahme"/>
        <label key="report.massnahme.label"></label>
        <!-- the properties of this report which the user must select before running it -->
                <values class="com.example.reports.massnahme.generator.MassnahmeUserGenerator"/>

In my report java class I add the WebResourceManager into the velocityParams and in my view.vm I call it in the first row:


In my view.vm I use a table-based presentation and I want to use a accordion technique to fold rows in my table. My javascript is loaded and the click listener works as intended. But my css file is completely ignored. When I inspect the page in chrome the css classes are not loaded at all. I tried some easy things like

    border: 1px solid black;

and nothing is showing up.

How do I have to define my css class for using it in a report? I was surprised to see that I can not add css or javascript to the report element itself. Or do I have an error in my code definition? Any ideas?

Apparently for CustomFields the approach using the method requireResource() is outdated and one should put these resources in <context>atl.general</context> . It worked directly with my reports too.