Current user not permitted to use Confluence error when getting app properties

Hello guys,

I need some help over here. I have an app that relies on an App Property we set.
However in some instances, I’m getting this error
body: '{"message":"Current user not permitted to use Confluence","statusCode":403}'
when getting the property.
This is how I get the property.

const httpClient = addon.httpClient({ clientKey: req.context.clientKey });
(err, response, body) => { 
   // code here 

Anyone has an idea why this is happening? This only happens for a few costumers.
Thanks in advance.


Hi @lfcgomes, it looks like you’re using Atlassian Connect Express to call the Confluence REST API. I can’t spot anything wrong with the way you are making the request so I wonder if the customers experiencing this issue have modified the permissions of their users to exclude access by the user associated with your app? Is this the only API call that fails or do other API calls by your app fail as well?

@dmorrow thank you for your help.
I asked the customer and I’m still waiting for a response. In the meantime, I’m trying to replicate that in my dev instance, but I’m not able to find where the app user / group is so I can change its permission. Would you mind guide me where I find that?


You should see the app user in the global permissions area of the admin area.

thanks @danielwester. I do have the following, but everything is working. I cannot revoke all permissions for that specific user

Thanks for helping @danielwester. Both the global and space permissions don’t seem to show the app user corresponding to a test app that I just installed in my test site. Comments in CONFCLOUD-69755 indicates others are seeing a similar issue.

:wave: all,

I just worked on a DEVHELP ticket with the same error message on the same end point and the issue was that the groups associated with the app didn’t have product access.

I couldn’t reproduce the exact issue in my test site, but adding the group associated with the app to the product access (Update product access settings | Atlassian Support) in the UI resolved the problem.

Atlassian customer support can help identifying the problem and restoring the access for the app on the affected sites.


1 Like