Cursor not-allowed on Forge macro app

Hi Team,

I’m going through this tutorial https://developer.atlassian.com/platform/forge/create-a-giphy-app-using-the-ui-kit/
But when I insert macro on confluence page it asks to “allow the app to access Atlassian products on your behalf”. The problem is that I can’t make any clicks on my macro body. My cursor is “not-allowed”. I do everything according to the tutorial. How can I fix it?

Thanks.

P.S.: I can fire click event on my macro body via AJS and buttons works fine (“Allow Access” for example).

1 Like

You’re in edit mode and that is a preview. If you publish the page you can click the button.

1 Like

We have run into this UX issue as well and filed FRGE-284 for it a couple of weeks ago, so you might want to vote for that. Regarding the ‘workaround’ of having to publish the page first, we stated:

Note that the workaround seems acceptable for this simplified reproduction, as it does not require any macro configuration. However, for more complex macros that require configuration before publishing, the workaround results in awkward and non intuitive UX , as we need to guide the user back to page edit, and then to macro edit mode after he already published the page.

2 Likes

Thank you so much!

We have run into this issue as well while building a Forge app and and while we currently don’t have an option aside from publishing the page, this is not an ideal user experience as there are valid use cases such as “allow access” , configuration in the confluence settings page or just clicking on documentation links that is sometimes necessary to do in the edit mode.

It would be great if a solution could be provided as it would help in developing user friendly Forge apps.

In the meantime, we will follow FRGE-284 as raised by @hopel.