Developing and testing jira app migration without automated path


I’m trying to implement a migration for the application which is available for Jira Server/DC and Jira Cloud and is used on production. I successfully registered CloudMigrationListenerV1 implementation based on the sample

Jira Cloud Migration Assistant shows that my application doesn’t have an automated migration path and doesn’t allow me to start application migration.
The message at “Would you like to migrate your apps?” step:
“We will migrate the data of the apps you selected where an automated migration path exists.”
According to

I need to add cloudMigrationAssistantCompatibility property to migration info on Atlassian Marketplace but this means that my application will become available for migration on production, right? But migration is not developed yet.
Is there a way to start my application migration at my local machine for development/testing without an automation path?
Thank you!

@DaniilKovalev I’d be really interested in the suggested solution for this too.

A workaround I can think of is to play with the versions. In the marketplace config you specify the version of your app that provides the migration path. You can use that to put a version that’d only match your non-production environments.

Hello @DaniilKovalev :wave:

Have you considered using dev mode?

It will enable you to bypass the Marketplace check and the App Assessment steps.



1 Like

Hi @AndreRosot,
Thank you for quick response.
Yes, I’ve tried dev mode but I don’t see any effect of this Dark Feature.
Here are my dark features (I also tried “com.atlassian.jira prefix”):

I only can add one embedded image in a post, so I’ll put more images in next posts.

I can select 1 app for migration

But I configured 2 apps as needed in cloud
The first app has automated path and I can add it to migration
The second app doesn’t have automated path and I can’t add it to migration despite “” is enabled.

If I proceed with JCMA wizard than only first app is ready for migration:

Thanks for the screenshots @DaniilKovalev.

You’re correct, when dev mode is used the user interface won’t behave exactly as it would in a normal migration. You can even disregard App Assessment completely (your third screenshot) and your migration listener would still be invoked.

So it really depends on the scope of your tests (or development). If you want to see the listener getting triggered and interacting with the platform, dev mode may be an answer. If you’re testing the whole user experience, @NikolaNedoklanov 's suggestion about registering a non-released version sounds a good idea.

Please let me know if that helps,


Many thanks for the explanation!
Finally, I got my migration listener triggered in dev mode as you described. Even if I don’t select any app for migration.
Seems the issue was at my end: some invalid plugin-context.xml. I’ve removed it and now onRegistrationAccepted is getting called and onStartAppMigration is getting called as well.
I will consider registering a non-released version option for testing.

@AndreRosot, @NikolaNedoklanov thank you for your help!