Dialogmodule is not working in admin_plugins_menu

Hello. For some reason dialogmodule is not working for admin_plugins_menu. I had no such issues with system.top.navigation.bar and didn’t find any information about such limits. Do anyone know if it is possible to use dialogmodule with admin_plugins_menu?

I found this task, that describes similar issue. But, unfortunately there is no answer, that will solve it.

That’s how it shows right now:

atlassian-connect.json

{
   "modules":{
      "generalPages":[
         {
            "key":"settings-page",
            "location":"admin_plugins_menu/admin-section",
            "name":{
               "value":"Admin Page"
            },
            "url":"/admin-page",
            "conditions":[
               {
                  "condition":"user_is_admin"
               }
            ]
         }
      ],
      "webItems":[
         {
            "key":"admin-section-dialog",
            "location":"admin_plugins_menu/admin-section",
            "name":{
               "value":"Admin Dialog"
            },
            "target":{
               "type":"dialogmodule",
               "options":{
                  "key":"dialog-1"
               }
            },
            "conditions":[
               {
                  "condition":"user_is_admin"
               }
            ]
         }
      ],
      "webSections":[
         {
            "location":"admin_plugins_menu",
            "key":"admin-section",
            "name":{
               "value":"Teamlead CRM"
            },
            "conditions":[
               {
                  "condition":"user_is_admin"
               }
            ]
         }
      ],
      "dialogs":[
         {
            "url":"/admin-dialog",
            "options":{
               "height":"220px",
               "width":"500px",
               "chrome":false
            },
            "key":"dialog-1"
         }
      ]
   }
}

Appreciate any help. Best regards, Igor.