Disabling Velocity Cache doesn't work with Actions?

Hi there,

i just found out that i can disable the Cache of the Velocity templates so that i don’t have to restart the server to see velocity changes. However i noticed that the changes are taking effect only when i am navigating to the .vm file through an Servlet. When i call the same .vm through an Action, the changes haven’t been applied. Is this a normal beheiviour and is there a way to fix that ?

Thank you


I never had problems with Velocity caching (I have never used the approach described in the links).
I just use -Datlassian.disable.caches=true. But then you still have to make sure that the updated velocity files are available to Confluence, so either you package and upload the plugin or you configure the additional resource folders, -Dplugin.resource.directories=/src

Hope that helps, Chris

HI Chris,

thank you for your response. I thought that being in dev mode, automatically disables the caches. However i did try everything you’ve suggested, but sadly without any success. What i find even more strange is, that when i call ConfluenceSystemProperties.isDisableCaches() inside my Action Class, it returns “false” no matter what i try (even with -Datlassian.disable.caches=true). I find it kind of annoying to have to package and upload the plugin (by using Quick Reload) every single time i make a slight change in the .vm file. As i said, if i use the templateRenderer in my Servlet, there is no need for using quick reload. The Problem appears only when im calling the vm through xwork actions. Has anyone any other thoughts on that topic?

Thanks in advance.


so after doing the exact same steps from Disable Velocity caching did the trick for me. I don’t know why it didn’t work the first time, but it looks fine now. The Topic can be closed :slight_smile:

I learned that this was a wrong assumption on my side; -Datlassian.disable.caches=true does not disable Velocity caching.